karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Freeman Fang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-1911) Could not start bundle mvn:org.apache.camel/camel-spring/2.7.0 with Karaf 2.2.9
Date Thu, 11 Oct 2012 08:37:02 GMT

    [ https://issues.apache.org/jira/browse/KARAF-1911?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13473959#comment-13473959
] 

Freeman Fang commented on KARAF-1911:
-------------------------------------

Hi,

This isn't a Karaf issue, Karaf by default didn't install any spring bundle at all.
This is caused by camel project feature pull in different spring version which cause conflict,
this should be resolved in camel by tune the feature/bundle version range. Camel 2.7.0 is
quite old and this issue I believe already get resolved for a long time, could you please
try more recent camel version like 2.10.x?

Anyway this isn't a Karaf issue.

Freeman
                
> Could not start bundle mvn:org.apache.camel/camel-spring/2.7.0 with Karaf 2.2.9
> -------------------------------------------------------------------------------
>
>                 Key: KARAF-1911
>                 URL: https://issues.apache.org/jira/browse/KARAF-1911
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 2.2.9
>         Environment: OpenJDK 1.6.0_24
>            Reporter: Robert Balent
>            Assignee: Freeman Fang
>
> I've just downloaded Apache Karaf 2.2.9 for linux and proceeded through Quick Start guide.
> I've typed:
> features:addurl mvn:org.apache.camel/camel-example-osgi/2.7.0/xml/features
> features:install camel-example-osgi
> And error is:
> Error executing command: Could not start bundle mvn:org.apache.camel/camel-spring/2.7.0
in feature(s) camel-spring-2.7.0: Uses constraint violation. Unable to resolve module org.apache.camel.camel-spring
\[79.0\] because it is exposed to package 'org.springframework.core' from modules org.springframework.core
\[51.0\] and org.springframework.core \[65.0\] via two dependency chains.
> Chain 1:
>   org.apache.camel.camel-spring \[79.0\]
>     import: (&(package=org.springframework.core)(version>=3.0.0)(!(version>=4.0.0)))
>      |
>     export: package=org.springframework.core
>   org.springframework.core \[51.0\]
> Chain 2:
>   org.apache.camel.camel-spring \[79.0\]
>     import: (&(package=org.springframework.osgi.context)(version>=1.2.0)(!(version>=2.0.0)))
>      |
>     export: package=org.springframework.osgi.context; uses:=org.springframework.beans
>   org.springframework.osgi.core \[74.0\]
>     import: (&(package=org.springframework.beans)(version>=2.5.6)(!(version>=4.0.0)))
>      |
>     export: package=org.springframework.beans; uses:=org.springframework.core
>   org.springframework.beans \[68.0\]
>     import: (&(package=org.springframework.core)(version>=3.0.7)(!(version>=3.0.8)))
>      |
>     export: package=org.springframework.core
>   org.springframework.core \[65.0\]
> It works with camel-example-osgi:2.6.0 version.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message