karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KARAF-1852) Osgi packages are exported with wrong versions
Date Fri, 21 Sep 2012 07:29:07 GMT
Guillaume Nodet created KARAF-1852:
--------------------------------------

             Summary: Osgi packages are exported with wrong versions
                 Key: KARAF-1852
                 URL: https://issues.apache.org/jira/browse/KARAF-1852
             Project: Karaf
          Issue Type: Bug
    Affects Versions: 2.3.0
            Reporter: Guillaume Nodet
             Fix For: 2.3.0


The versions of the packages have not been updated when upgrading to osgi 4.3.
The correct list is the following:

{code}
org.osgi.framework.system.packages= \
 org.osgi.framework.startlevel;uses:="org.osgi.framework";version="1.0", \
 org.osgi.framework.wiring;uses:="org.osgi.resource,org.osgi.framework";version="1.1", \
 org.osgi.framework.hooks.bundle;uses:="org.osgi.framework";version="1.1", \
 org.osgi.framework.hooks.service;uses:="org.osgi.framework";version="1.1", \
 org.osgi.framework.hooks.resolver;uses:="org.osgi.framework.wiring";version="1.0", \
 org.osgi.framework.launch;uses:="org.osgi.framework";version="1.1", \
 org.osgi.framework.namespace;uses:="org.osgi.resource";version="1.0", \
 org.osgi.framework;version="1.7",\
 org.osgi.framework.hooks.weaving;uses:="org.osgi.framework.wiring";version="1.0",\
 org.osgi.resource;version="1.0",org.osgi.service.url;version="1.0",\
 org.osgi.service.startlevel;uses:="org.osgi.framework";version="1.1",\
 org.osgi.service.packageadmin;uses:="org.osgi.framework";version="1.2",\
 org.osgi.service.url;version="1.0", \
 org.osgi.util.tracker;uses:="org.osgi.framework";version="1.5.1", \
 org.apache.karaf.jaas.boot;version="${karaf.osgi.version}", \
 org.apache.karaf.jaas.boot.principal;version="${karaf.osgi.version}", \
 org.apache.karaf.version;version="${karaf.osgi.version}", \
 ${jre-${java.specification.version}}
{code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message