karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Created] (KARAF-1845) Minimal distribution doesn't start
Date Tue, 18 Sep 2012 14:11:07 GMT
Jean-Baptiste Onofré created KARAF-1845:
-------------------------------------------

             Summary: Minimal distribution doesn't start
                 Key: KARAF-1845
                 URL: https://issues.apache.org/jira/browse/KARAF-1845
             Project: Karaf
          Issue Type: Bug
          Components: karaf-core
            Reporter: Jean-Baptiste Onofré
             Fix For: 2.3.0


When starting the minimal distribution, all commands fail to load:

ERROR: Bundle org.apache.karaf.shell.packages [29] Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.packages/2.3.0-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages
[29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sshd.agent)(version>=0.7.0)(!(version>=1.0.0)))])
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages
[29]: Unable to resolve 29.0: missing requirement [29.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
[caused by: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sshd.agent)(version>=0.7.0)(!(version>=1.0.0)))]


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message