karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-1684) org.apache.karaf.shell.ssh under wrapper throws UnsupportedClassVersionError: com/sun/crypto/provider/SunJCE : Unsupported major.minor version 51.0 under Ubuntu 12.04 OpenJDK 7 i386
Date Mon, 30 Jul 2012 05:44:34 GMT

    [ https://issues.apache.org/jira/browse/KARAF-1684?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13424707#comment-13424707
] 

Jean-Baptiste Onofré commented on KARAF-1684:
---------------------------------------------

JDK 7 is not supported with Karaf 2.2.x. Anyway, I gonna take a look.
                
> org.apache.karaf.shell.ssh under wrapper throws UnsupportedClassVersionError: com/sun/crypto/provider/SunJCE
: Unsupported major.minor version 51.0 under Ubuntu 12.04 OpenJDK 7 i386
> -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: KARAF-1684
>                 URL: https://issues.apache.org/jira/browse/KARAF-1684
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-os-integration
>    Affects Versions: 2.2.8, 2.3.0
>         Environment: Linux 3.4.2-linode44 #1 SMP Tue Jun 12 15:04:46 EDT 2012 i686 i686
i386 GNU/Linux
> java version "1.7.0_03"
> OpenJDK Runtime Environment (IcedTea7 2.1.1pre) (7~u3-2.1.1~pre1-1ubuntu3)
> OpenJDK Client VM (build 22.0-b10, mixed mode, sharing)
>            Reporter: Hendy Irawan
>
> {code}
>  37 - org.apache.karaf.shell.ssh - 2.3.0.SNAPSHOT | ServiceEvent UNREGISTERING
> 2012-07-29 20:17:14,554 | ERROR | rint Extender: 3 | BlueprintContainerImpl         
 | 9 - org.apache.aries.blueprint - 0.3.2 | Unable to start blueprint container for bundle
org.apache.karaf.shell.ssh
> org.osgi.service.blueprint.container.ComponentDefinitionException: Error when instanciating
bean sshServer of class class org.apache.sshd.SshServer
>         at org.apache.aries.blueprint.container.BeanRecipe.getInstance(BeanRecipe.java:253)[9:org.apache.aries.blueprint:0.3.2]
>         at org.apache.aries.blueprint.container.BeanRecipe.internalCreate(BeanRecipe.java:708)[9:org.apache.aries.blueprint:0.3.2]
>         at org.apache.aries.blueprint.di.AbstractRecipe.create(AbstractRecipe.java:64)[9:org.apache.aries.blueprint:0.3.2]
>         at org.apache.aries.blueprint.container.BlueprintRepository.createInstances(BlueprintRepository.java:219)[9:org.apache.aries.blueprint:0.3.2]
>         at org.apache.aries.blueprint.container.BlueprintRepository.createAll(BlueprintRepository.java:147)[9:org.apache.aries.blueprint:0.3.2]
>         at org.apache.aries.blueprint.container.BlueprintContainerImpl.instantiateEagerComponents(BlueprintContainerImpl.java:631)[9:org.apache.aries.blueprint:0.3.2]
>         at org.apache.aries.blueprint.container.BlueprintContainerImpl.doRun(BlueprintContainerImpl.java:337)[9:org.apache.aries.blueprint:0.3.2]
>         at org.apache.aries.blueprint.container.BlueprintContainerImpl.run(BlueprintContainerImpl.java:230)[9:org.apache.aries.blueprint:0.3.2]
>         at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)[:1.6.0_24]
>         at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)[:1.6.0_24]
>         at java.util.concurrent.FutureTask.run(FutureTask.java:166)[:1.6.0_24]
>         at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:165)[:1.6.0_24]
>         at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:266)[:1.6.0_24]
>         at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)[:1.6.0_24]
>         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)[:1.6.0_24]
>         at java.lang.Thread.run(Thread.java:679)[:1.6.0_24]
> Caused by: java.lang.UnsupportedClassVersionError: com/sun/crypto/provider/SunJCE : Unsupported
major.minor version 51.0
>         at java.lang.ClassLoader.defineClass1(Native Method)[:1.6.0_24]
>         at java.lang.ClassLoader.defineClass(ClassLoader.java:634)[:1.6.0_24]
>         at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)[:1.6.0_24]
>         at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)[:1.6.0_24]
>         at java.net.URLClassLoader.access$000(URLClassLoader.java:73)[:1.6.0_24]
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:212)[:1.6.0_24]
>         at java.security.AccessController.doPrivileged(Native Method)[:1.6.0_24]
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:205)[:1.6.0_24]
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:321)[:1.6.0_24]
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:314)[:1.6.0_24]
>         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)[:1.6.0_24]
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:266)[:1.6.0_24]
>         at sun.security.jca.ProviderConfig$3.run(ProviderConfig.java:253)[:1.6.0_24]
>         at sun.security.jca.ProviderConfig$3.run(ProviderConfig.java:244)[:1.6.0_24]
>         at java.security.AccessController.doPrivileged(Native Method)[:1.6.0_24]
>         at sun.security.jca.ProviderConfig.doLoadProvider(ProviderConfig.java:244)[:1.6.0_24]
>         at sun.security.jca.ProviderConfig.getProvider(ProviderConfig.java:224)[:1.6.0_24]
>         at sun.security.jca.ProviderList.getProvider(ProviderList.java:232)[:1.6.0_24]
>         at sun.security.jca.ProviderList$ServiceList.tryGet(ProviderList.java:433)[:1.6.0_24]
>         at sun.security.jca.ProviderList$ServiceList.access$200(ProviderList.java:375)[:1.6.0_24]
>         at sun.security.jca.ProviderList$ServiceList$1.hasNext(ProviderList.java:485)[:1.6.0_24]
>         at javax.crypto.Cipher.getInstance(Cipher.java:429)[:1.6.0_24]
>         at org.apache.sshd.common.util.SecurityUtils.getCipher(SecurityUtils.java:118)
>         at org.apache.sshd.common.cipher.BaseCipher.init(BaseCipher.java:59)
>         at org.apache.sshd.SshServer.setUpDefaultCiphers(SshServer.java:521)
>         at org.apache.sshd.SshServer.setUpDefaultServer(SshServer.java:479)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[:1.6.0_24]
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)[:1.6.0_24]
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)[:1.6.0_24]
>         at java.lang.reflect.Method.invoke(Method.java:616)[:1.6.0_24]
>         at org.apache.aries.blueprint.utils.ReflectionUtils.invoke(ReflectionUtils.java:225)[9:org.apache.aries.blueprint:0.3.2]
>         at org.apache.aries.blueprint.container.BeanRecipe.invoke(BeanRecipe.java:838)[9:org.apache.aries.blueprint:0.3.2]
>         at org.apache.aries.blueprint.container.BeanRecipe.getInstance(BeanRecipe.java:251)[9:org.apache.aries.blueprint:0.3.2]
>         ... 15 more
> {code}
> BTW this might be a clue :
> {code}
> 2012-07-29 20:26:54,554 | INFO  | rint Extender: 1 | SecurityUtils                  
 |
>  22 - org.apache.sshd.core - 0.7.0 | BouncyCastle not registered, using the default JCE
>  provider
> {code}
> The bug doesn't happen on:
> 1. OpenJDK 6 : whether running inside wrapper or not
> java version "1.6.0_24"
> OpenJDK Runtime Environment (IcedTea6 1.11.3) (6b24-1.11.3-1ubuntu0.12.04.1)
> OpenJDK Client VM (build 20.0-b12, mixed mode, sharing)
> 2. OpenJDK 7 : IF run from standard bin/karaf launcher (i.e. not using wrapper)
> java version "1.7.0_03"
> OpenJDK Runtime Environment (IcedTea7 2.1.1pre) (7~u3-2.1.1~pre1-1ubuntu3)
> OpenJDK Client VM (build 22.0-b10, mixed mode, sharing)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message