karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Achim Nierbeck (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-1523) Gemini Blueprint with start error
Date Wed, 06 Jun 2012 13:19:23 GMT

    [ https://issues.apache.org/jira/browse/KARAF-1523?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13290140#comment-13290140
] 

Achim Nierbeck commented on KARAF-1523:
---------------------------------------

yes, Gemini Blueprint is incompatible with Spring 3.1.x. This is a known issue, a newer version
of Gemini Blueprint should be compatible again. 
I think it's something like 1.0.1-SNAPSHOT of Gemini-Blueprint. 
                
> Gemini Blueprint with start error
> ---------------------------------
>
>                 Key: KARAF-1523
>                 URL: https://issues.apache.org/jira/browse/KARAF-1523
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-core
>         Environment: Karaf 3.0-SNAPSHOT,JDK 1.6,Mac Lion.
>            Reporter: Ford Guo
>
> when I feature:install gemini-blueprint,I got such exception:
> Caused by: java.lang.NoSuchFieldError: NULL
>         at org.eclipse.gemini.blueprint.blueprint.container.SpringBlueprintConverterService.convert(SpringBlueprintConverterService.java:93)
>         at org.springframework.beans.TypeConverterDelegate.convertIfNecessary(TypeConverterDelegate.java:143)[71:org.springframework.beans:3.1.1.RELEASE]
>         at org.springframework.beans.BeanWrapperImpl.convertIfNecessary(BeanWrapperImpl.java:470)[71:org.springframework.beans:3.1.1.RELEASE]
>         at org.springframework.beans.BeanWrapperImpl.convertForProperty(BeanWrapperImpl.java:516)[71:org.springframework.beans:3.1.1.RELEASE]
>         at org.springframework.beans.BeanWrapperImpl.convertForProperty(BeanWrapperImpl.java:510)[71:org.springframework.beans:3.1.1.RELEASE]
>         at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.convertForProperty(AbstractAutowireCapableBeanFactory.java:1406)[71:org.springframework.beans:3.1.1.RELEASE]
>         at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyPropertyValues(AbstractAutowireCapableBeanFactory.java:1365)[71:org.springframework.beans:3.1.1.RELEASE]

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message