karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Achim Nierbeck (JIRA)" <j...@apache.org>
Subject [jira] [Issue Comment Edited] (KARAF-1415) Support Jetty 7.6
Date Fri, 27 Apr 2012 23:24:51 GMT

    [ https://issues.apache.org/jira/browse/KARAF-1415?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13263699#comment-13263699
] 

Achim Nierbeck edited comment on KARAF-1415 at 4/27/12 11:24 PM:
-----------------------------------------------------------------

I'm on the Jetty 7.6.3 upgrade right now, it also needs special handling with pax-web. 
So a upgrade to pax-web 1.1.3 is also needed. Will try this weekend to complete these tasks.

@Freeman, you mind if I take this one?
                
      was (Author: achim_nierbeck):
    I'm on the Jetty 7.6.3 upgrade right now, it also needs special handling with pax-web.

So a upgrade to pax-web 1.1.3 is also needed. Will try this weekend to complete these tasks.
                  
> Support Jetty 7.6
> -----------------
>
>                 Key: KARAF-1415
>                 URL: https://issues.apache.org/jira/browse/KARAF-1415
>             Project: Karaf
>          Issue Type: Task
>            Reporter: Claus Ibsen
>            Assignee: Freeman Fang
>             Fix For: 2.3.0
>
>
> The feature file of Karaf uses Jetty 7.5.
> In Camel if you want to use Jetty 7.6 then thats not possible with Karaf out of the box,
as we use the jetty feature from Karaf.
> So if camel-jetty is build with Jetty 7.6, then the osgi manifest adds a new package
or something 
> Nevertheless you get this problem when install camel-jetty in karaf 2.2.x
> I suspect the package org.eclipse.jetty.util.ssl
> 2012-04-27 08:23:15.190:INFO:oejs.Server:jetty-7.5.4.v20111024
> 2012-04-27 08:23:15.230:INFO:oejs.AbstractConnector:Started NIOSocketConnectorWrapper@0.0.0.0:8080
STARTING
> ERROR: Error starting file:bundles/org.apache.camel.camel-jetty_2.10.0.SNAPSHOT.jar (org.osgi.framework.BundleException:
Unresolved constraint in bundle org.apache.camel.camel-jetty [73]: Unable to resolve 73.0:
missing requirement [73.0] package; (&(package=org.eclipse.jetty.util.ssl)(version>=7.0.0)(!(version>=8.0.0))))
> org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-jetty
[73]: Unable to resolve 73.0: missing requirement [73.0] package; (&(package=org.eclipse.jetty.util.ssl)(version>=7.0.0)(!(version>=8.0.0)))
> 	at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3404)
> 	at org.apache.felix.framework.Felix.startBundle(Felix.java:1714)
> 	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1143)
> 	at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
> 	at java.lang.Thread.run(Thread.java:680)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message