karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Meifang Shen (Created) (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KARAF-1330) "cluster:feature-uninstall" command only worked for current group but didn't work for other group
Date Fri, 06 Apr 2012 05:46:28 GMT
"cluster:feature-uninstall" command only worked for current group but didn't work for other
group
-------------------------------------------------------------------------------------------------

                 Key: KARAF-1330
                 URL: https://issues.apache.org/jira/browse/KARAF-1330
             Project: Karaf
          Issue Type: Bug
          Components: cellar-features
    Affects Versions: 2.2.4
            Reporter: Meifang Shen


There are three cluster nodes in default group, also there is an user defined group "testGrp"
and no node in it.

When use karaf command or cluster command to uninstall feature, both are ok for the current
group "default", But use cluster command to uninstall feature in the group "testGrp", it failed,
feature couldn't be uninstalled.

Vice versa, all three cluster nodes are in group "testGrp", no node in default group.

Please have a look at those below commands.
{noformat} 
karaf@trun> cluster:group-list
  Node                 Group
  TALENDSSHEN:5703     default
* TALENDSSHEN:5701     default
  TALENDSSHEN:5702     default
		       testGrp
 
karaf@trun> features:uninstall tesb-zookeeper
karaf@trun> feature-list default
tesb-zookeeper    5.1.0-SNAPSHOT    false
 
karaf@trun> feature-uninstall default activemq
karaf@trun> feature-list default
activemq    5.5.0    false

karaf@trun> feature-uninstall testGrp activemq
karaf@trun> feature-list testGrp
activemq    5.5.0    true
{noformat} 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message