karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hendy Irawan (Created) (JIRA)" <j...@apache.org>
Subject [jira] [Created] (KARAF-1234) dev:dynamic-import does not work on wrap:mvn:org.neo4j/neo4j-kernel/1.6
Date Mon, 27 Feb 2012 15:54:48 GMT
dev:dynamic-import does not work on wrap:mvn:org.neo4j/neo4j-kernel/1.6
-----------------------------------------------------------------------

                 Key: KARAF-1234
                 URL: https://issues.apache.org/jira/browse/KARAF-1234
             Project: Karaf
          Issue Type: Bug
          Components: karaf-osgi
    Affects Versions: 2.2.5
            Reporter: Hendy Irawan


Install neo4j-kernel and let it get wrapped:

install wrap:mvn:org.neo4j/neo4j-kernel/1.6

Enable dynamic import on it, error occurs:

{code}
karaf@root> dev:dynamic-import 93
Enabling dynamic imports on bundle neo4j-kernel [93]
Error executing command: Invalid syntax for instruction [Bundle-Version=1.6$Bundle-UpdateLocation=wrap:file:/home/ceefour/apache-karaf-2.2.5/deploy/neo4j-kernel-1.6.jar$Bundle-SymbolicName=neo4j-kernel].
Take a look at http://www.aqute.biz/Code/Bnd.      
{code}

Dynamic imports need to be enabled because it indirectly "depends" on neo4j-lucene-index artifact.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message