karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jamie goodyear (Closed) (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (KARAF-473) Support version resolving in FeatureService#getFeatures(name/version)
Date Wed, 11 Jan 2012 16:52:41 GMT

     [ https://issues.apache.org/jira/browse/KARAF-473?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jamie goodyear closed KARAF-473.
--------------------------------

    
> Support version resolving in FeatureService#getFeatures(name/version)
> ---------------------------------------------------------------------
>
>                 Key: KARAF-473
>                 URL: https://issues.apache.org/jira/browse/KARAF-473
>             Project: Karaf
>          Issue Type: New Feature
>            Reporter: Andreas Pieber
>            Assignee: Andreas Pieber
>             Fix For: 2.2.0, 3.0.0
>
>         Attachments: 0001-KARAF-473-FeatureService-getFeatures-handles-version.patch
>
>
> The problem is that FeatureService#getFeatures(name/version) does not support ranges
such as (3,4]. This is a real problem if working with pax-exam and the latest features.xml.
To be able to run pax-exam with karaf-2.2.0 this have to make it's way into the 2.2.0 version
too

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message