karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jamie goodyear (Closed) (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (KARAF-1104) Add plexus-utils dependency to features-maven-plugin to allow it to work with Maven 2.2.x to create KARs
Date Fri, 27 Jan 2012 14:58:10 GMT

     [ https://issues.apache.org/jira/browse/KARAF-1104?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jamie goodyear closed KARAF-1104.
---------------------------------

    
> Add plexus-utils dependency to features-maven-plugin to allow it to work with Maven 2.2.x
to create KARs
> --------------------------------------------------------------------------------------------------------
>
>                 Key: KARAF-1104
>                 URL: https://issues.apache.org/jira/browse/KARAF-1104
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 2.2.5
>            Reporter: Jamie goodyear
>            Assignee: Jamie goodyear
>             Fix For: 2.2.5
>
>
> Features maven plugin is affected by a Maven 2 issue with picking up plexus-utils version
1.1.
> In some cases we need to pick up a more recent version of plexus-utils, unfortunately
on Maven 2 version plexus-utils 1.1 is automatically picked, Maven 3 does not share this issue.
> To resolved this issue i'd like to add a dependency in features-maven-plugin to pick
up version 2.1 of plexus-utils. With this dependency correct the features plugin create-kar
goal will work using Maven 2.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message