karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Achim Nierbeck (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KARAF-1048) make pom.xml eclipse 3.7 m2e friendly
Date Sun, 27 Nov 2011 22:06:40 GMT

    [ https://issues.apache.org/jira/browse/KARAF-1048?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13158044#comment-13158044
] 

Achim Nierbeck commented on KARAF-1048:
---------------------------------------

@Andrei: after trying this it doesn't work with the following message - This profile can not
be resolved because required software could not be located. 
So why don't you paste your proposal of the changes of the pom to pastebin or something the
like. 
                
> make pom.xml eclipse 3.7 m2e friendly
> -------------------------------------
>
>                 Key: KARAF-1048
>                 URL: https://issues.apache.org/jira/browse/KARAF-1048
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-core
>            Reporter: Andrei Pozolotin
>
> currently it is impossible to import karaf projects from svn in 
> eclipse 3.7 with m2e integration w/o need to manually
> provide m2e life cycle entries such as this,
> for all kinds of plugins
> ##################################
>                 <!--This plugin's configuration is used to store Eclipse m2e settings
only. It has no influence on the Maven build itself.-->
>                 <plugin>
>                 	<groupId>org.eclipse.m2e</groupId>
>                 	<artifactId>lifecycle-mapping</artifactId>
>                 	<version>1.0.0</version>
>                 	<configuration>
>                 		<lifecycleMappingMetadata>
>                 			<pluginExecutions>
>                 				<pluginExecution>
>                 					<pluginExecutionFilter>
>                 						<groupId>
>                 							org.apache.felix
>                 						</groupId>
>                 						<artifactId>
>                 							maven-bundle-plugin
>                 						</artifactId>
>                 						<versionRange>
>                 							[2.3.5,)
>                 						</versionRange>
>                 						<goals>
>                 							<goal>cleanVersions</goal>
>                 						</goals>
>                 					</pluginExecutionFilter>
>                 					<action>
>                 						<ignore></ignore>
>                 					</action>
>                 				</pluginExecution>
>                 			</pluginExecutions>
>                 		</lifecycleMappingMetadata>
>                 	</configuration>
>                 </plugin>

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message