karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet (Resolved) (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (KARAF-812) Cannot start bundle built with org.osgi.framework v. 4.3.0
Date Thu, 24 Nov 2011 16:33:40 GMT

     [ https://issues.apache.org/jira/browse/KARAF-812?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Guillaume Nodet resolved KARAF-812.
-----------------------------------

    Resolution: Fixed
    
> Cannot start bundle built with org.osgi.framework v. 4.3.0
> ----------------------------------------------------------
>
>                 Key: KARAF-812
>                 URL: https://issues.apache.org/jira/browse/KARAF-812
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-osgi
>    Affects Versions: 2.2.3
>            Reporter: Alexey Markevich
>             Fix For: 3.0.0
>
>
> I have a project with dependency
>         <dependency>
>             <groupId>org.osgi</groupId>
>             <artifactId>org.osgi.core</artifactId>
>             <version>${osgi.core.version}</version>
>             <scope>provided</scope>
>         </dependency>
> After switching to
>         <osgi.core.version>4.3.0</osgi.core.version>
> There is exception during bundle startup:
> Missing Constraint: Import-Package: org.osgi.framework; version="[1.6.0,2.0.0)"

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message