karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-638) Use the same naming convention in commands
Date Fri, 13 May 2011 12:26:47 GMT

    [ https://issues.apache.org/jira/browse/KARAF-638?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13032984#comment-13032984
] 

Jean-Baptiste Onofré commented on KARAF-638:
--------------------------------------------

For backward compatibility, the "old" styled commands could be present as aliases.

> Use the same naming convention in commands
> ------------------------------------------
>
>                 Key: KARAF-638
>                 URL: https://issues.apache.org/jira/browse/KARAF-638
>             Project: Karaf
>          Issue Type: Improvement
>          Components: console
>            Reporter: Jean-Baptiste Onofré
>             Fix For: 3.0.0
>
>
> In Karaf commands, we should use the same naming convention.
> For instance, we have commands looking like:
> admin:change-rmi-server-port
> admin:change-rmi-registry-port
> dev:create-dump
> and others looking like:
> roleadd
> roledel
> features:listversions
> To be clear for the users, I propose to adopt the same naming convention for all commands,
like:
> role-add
> role-del
> features:list-versions

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message