karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Pieber (JIRA)" <j...@apache.org>
Subject [jira] Created: (KARAF-473) Support version resolving in FeatureService#getFeatures(name/version)
Date Sun, 20 Feb 2011 04:04:38 GMT
Support version resolving in FeatureService#getFeatures(name/version)
---------------------------------------------------------------------

                 Key: KARAF-473
                 URL: https://issues.apache.org/jira/browse/KARAF-473
             Project: Karaf
          Issue Type: New Feature
            Reporter: Andreas Pieber
            Assignee: Andreas Pieber
             Fix For: 2.2.0, 3.0.0


The problem is that FeatureService#getFeatures(name/version) does not support ranges such
as (3,4]. This is a real problem if working with pax-exam and the latest features.xml. To
be able to run pax-exam with karaf-2.2.0 this have to make it's way into the 2.2.0 version
too

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message