karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charles Moulliard (JIRA)" <j...@apache.org>
Subject [jira] Created: (KARAF-414) The apache-karaf-2.1.99-SNAPSHOT-minimal.tar.gz generated contains unresolved dependencies
Date Mon, 24 Jan 2011 13:27:44 GMT
The apache-karaf-2.1.99-SNAPSHOT-minimal.tar.gz generated contains unresolved dependencies
------------------------------------------------------------------------------------------

                 Key: KARAF-414
                 URL: https://issues.apache.org/jira/browse/KARAF-414
             Project: Karaf
          Issue Type: Bug
            Reporter: Charles Moulliard
             Fix For: 2.2.0


The apache-karaf-2.1.99-SNAPSHOT-minimal generated during assembly of Karaf contains unresolved
dependencies

{code}
ERROR: Error starting mvn:org.apache.aries.blueprint/org.apache.aries.blueprint/0.3-SNAPSHOT
(org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint
[7]: Unable to resolve 7.0: missing requirement [7.0] package; (&(package=org.apache.aries.proxy)(version>=0.3.0)(!(version>=1.0.0))))
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint
[7]: Unable to resolve 7.0: missing requirement [7.0] package; (&(package=org.apache.aries.proxy)(version>=0.3.0)(!(version>=1.0.0)))
	at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
	at org.apache.felix.framework.Felix.startBundle(Felix.java:1719)
	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148)
	at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
	at java.lang.Thread.run(Thread.java:636)
ERROR: Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx/0.3-SNAPSHOT (org.osgi.framework.BundleException:
Unresolved constraint in bundle org.apache.aries.jmx [8]: Unable to resolve 8.0: missing requirement
[8.0] package; (&(package=org.apache.aries.util)(version>=0.3.0)(!(version>=1.0.0))))
org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx [8]:
Unable to resolve 8.0: missing requirement [8.0] package; (&(package=org.apache.aries.util)(version>=0.3.0)(!(version>=1.0.0)))
	at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
	at org.apache.felix.framework.Felix.startBundle(Felix.java:1719)
	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148)
	at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
	at java.lang.Thread.run(Thread.java:636)

{code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message