karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Pieber (JIRA)" <j...@apache.org>
Subject [jira] Updated: (KARAF-326) eclipse:eclipse importing error
Date Sat, 11 Dec 2010 19:25:02 GMT

     [ https://issues.apache.org/jira/browse/KARAF-326?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andreas Pieber updated KARAF-326:
---------------------------------

    Attachment: eclipse-error-fix.patch

The patch can be applied to the trunk as well as karaf-2.1.x and fixes the issue by excluding
org.osgi/org.osgi.core from various felix bundles. All integration tests (and my internal
tests using karaf in a similar way as smx uses it) also work. BUT the import in eclipse works
now :)

> eclipse:eclipse importing error
> -------------------------------
>
>                 Key: KARAF-326
>                 URL: https://issues.apache.org/jira/browse/KARAF-326
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 2.1.3, 2.2.0
>            Reporter: Andreas Pieber
>             Fix For: 2.1.3, 2.2.0
>
>         Attachments: eclipse-error-fix.patch
>
>
> Reproduce:
> * mvn clean install eclipse:eclipse
> * Use "import existing projects" in eclipse
> Error:
> Eclipse imports org.osgi/org.osgi.core/4.1.0 BEFORE it imports org.apache.felix/org.osgi.core/1.4.0.
Since the first artifact does not contains a Bundle#getVersion method this produces build
errors in eclipse. It works for mvn since the second is imported first (build order; you can
see this using mvn clean install -X).
> Fix:
> Ignore org.osgi/org.osgi.core/4.1.0 since we do not require it at all.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message