karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet (JIRA)" <j...@apache.org>
Subject [jira] Commented: (KARAF-328) Define Java version policy for Karaf
Date Tue, 14 Dec 2010 19:51:01 GMT

    [ https://issues.apache.org/jira/browse/KARAF-328?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12971387#action_12971387
] 

Guillaume Nodet commented on KARAF-328:
---------------------------------------

Are you proposing we get rid of JDK 1.5 support and move the requirement to 1.6 ?
I think this should be discussed on the mailing list so that people don't miss the discussion.

> Define Java version policy for Karaf
> ------------------------------------
>
>                 Key: KARAF-328
>                 URL: https://issues.apache.org/jira/browse/KARAF-328
>             Project: Karaf
>          Issue Type: Task
>          Components: documentation
>            Reporter: Ɓukasz Dywicki
>
> Currently Karaf build on Hundson uses JDK 1.5, however it's a bit outdated environment.
JDK 1.5 was released in May 2004.
> I don't think that JDK 1.5 is bad and should not be supported but most of developers
(including me) uses JDK 1.6 as local build environment with compile target 1.5 what causes
some problems (eg Karaf builds #229, #230).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message