karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Achim Nierbeck (JIRA)" <j...@apache.org>
Subject [jira] Assigned: (KARAF-326) eclipse:eclipse importing error
Date Sat, 18 Dec 2010 20:20:02 GMT

     [ https://issues.apache.org/jira/browse/KARAF-326?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Achim Nierbeck reassigned KARAF-326:
------------------------------------

    Assignee: Achim Nierbeck

> eclipse:eclipse importing error
> -------------------------------
>
>                 Key: KARAF-326
>                 URL: https://issues.apache.org/jira/browse/KARAF-326
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 2.1.3, 2.2.0
>            Reporter: Andreas Pieber
>            Assignee: Achim Nierbeck
>             Fix For: 2.1.3, 2.2.0
>
>         Attachments: eclipse-error-fix.patch
>
>
> Reproduce:
> * mvn clean install eclipse:eclipse
> * Use "import existing projects" in eclipse
> Error:
> Eclipse imports org.osgi/org.osgi.core/4.1.0 BEFORE it imports org.apache.felix/org.osgi.core/1.4.0.
Since the first artifact does not contains a Bundle#getVersion method this produces build
errors in eclipse. It works for mvn since the second is imported first (build order; you can
see this using mvn clean install -X).
> Fix:
> Ignore org.osgi/org.osgi.core/4.1.0 since we do not require it at all.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message