karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Drozdov (JIRA)" <j...@apache.org>
Subject [jira] Updated: (KARAF-265) add-features-to-repo goal of features-maven-plugin should support wrap jar
Date Wed, 03 Nov 2010 00:14:23 GMT

     [ https://issues.apache.org/jira/browse/KARAF-265?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmitry Drozdov updated KARAF-265:
---------------------------------

          Description: 
The bundles with wrap prefix are currently skipped, please fix.

Please also note that wrap prefix allows additional params to be specified after bundle version,
using $ sign, like this:
<bundle>wrap:mvn:org.apache.shiro/shiro-core/1.0.0-incubating$Bundle-Version=1.0.0&amp;Export-Package=*;version="1.0.0"</bundle>
this is currently not handled properly:

[ERROR] Can't resolve bundle mvn:org.apache.shiro/shiro-core/1.0.0-incubating$Bundle-Version=1.0.0&Export-Package=*;version="1.0.0"
org.apache.maven.artifact.resolver.ArtifactNotFoundException: Unable to download the artifact
from any repository

the $ sign and everything after it should be removed from the URL when downloading the bundle

  was:be able to download it and validate the wrap jar

    Affects Version/s: 2.0.0

> add-features-to-repo goal of features-maven-plugin should support wrap jar
> --------------------------------------------------------------------------
>
>                 Key: KARAF-265
>                 URL: https://issues.apache.org/jira/browse/KARAF-265
>             Project: Karaf
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Dmitry Drozdov
>            Assignee: Freeman Fang
>             Fix For: 2.1.1, 2.2.0
>
>
> The bundles with wrap prefix are currently skipped, please fix.
> Please also note that wrap prefix allows additional params to be specified after bundle
version, using $ sign, like this:
> <bundle>wrap:mvn:org.apache.shiro/shiro-core/1.0.0-incubating$Bundle-Version=1.0.0&amp;Export-Package=*;version="1.0.0"</bundle>
> this is currently not handled properly:
> [ERROR] Can't resolve bundle mvn:org.apache.shiro/shiro-core/1.0.0-incubating$Bundle-Version=1.0.0&Export-Package=*;version="1.0.0"
> org.apache.maven.artifact.resolver.ArtifactNotFoundException: Unable to download the
artifact from any repository
> the $ sign and everything after it should be removed from the URL when downloading the
bundle

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message