karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet (JIRA)" <j...@apache.org>
Subject [jira] Updated: (KARAF-251) Allow the use of version ranges on dependant features
Date Wed, 20 Oct 2010 13:59:24 GMT

     [ https://issues.apache.org/jira/browse/KARAF-251?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Guillaume Nodet updated KARAF-251:
----------------------------------

    Issue Type: New Feature  (was: Improvement)

> Allow the use of version ranges on dependant features
> -----------------------------------------------------
>
>                 Key: KARAF-251
>                 URL: https://issues.apache.org/jira/browse/KARAF-251
>             Project: Karaf
>          Issue Type: New Feature
>          Components: runtime
>            Reporter: Guillaume Nodet
>            Assignee: Guillaume Nodet
>             Fix For: 2.2.0
>
>
> For example, often, libraries can depend on spring 2.5 or spring 3.x and the only way
is to have two separate list of features.
> A range would allow selecting one or the other.
> The default behavior would be:
>   * if no version is indicated, it means [0, +oo)
>   * if a version is indicated, the range is closed [x, x]
>   * if a feature matching the range is already installed, use that one
>   * else find the highest version matching the range

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message