karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (KARAF-190) karaf-wrapper.conf is incorrect
Date Fri, 10 Sep 2010 07:15:34 GMT

     [ https://issues.apache.org/jira/browse/KARAF-190?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Guillaume Nodet resolved KARAF-190.
-----------------------------------

    Resolution: Fixed

The wrapper integration has been rewritten and those problems seem to be fixed already in
2.1

> karaf-wrapper.conf is incorrect
> -------------------------------
>
>                 Key: KARAF-190
>                 URL: https://issues.apache.org/jira/browse/KARAF-190
>             Project: Karaf
>          Issue Type: Bug
>          Components: wrapper
>    Affects Versions: 2.0.0
>         Environment: Windows 
>            Reporter: dimitri herla
>            Assignee: Guillaume Nodet
>             Fix For: 2.1.0
>
>
> I use the FUSE ESB version 4.3.
> I install the feature wrapper and after I execute the wrapper:install.
> There are some problems :
> 1. The jar 'karaf-wrapper.jar' is corrupted
> 2. The karaf-wrapper.conf is invalid
>    2.1. The following line : set.default.KARAF_DATA=${karaf.data} create a stackOverFlow
at execution :
> jvm 1 | WrapperSimpleApp: invoking main method
> jvm 1 | Could not create framework: java.lang.StackOverflowError
> jvm 1 | java.lang.StackOverflowError
> jvm 1 | at java.util.HashMap.put(Unknown Source)
> jvm 1 | at org.apache.karaf.main.Main.substVars(Main.java:1017)
> jvm 1 | at org.apache.karaf.main.Main.substVars(Main.java:1091)
> jvm 1 | at org.apache.karaf.main.Main.substVars(Main.java:1091)
> jvm 1 | at org.apache.karaf.main.Main.substVars(Main.java:1091)
> jvm 1 | at org.apache.karaf.main.Main.substVars(Main.java:1091)
> jvm 1 | at org.apache.karaf.main.Main.substVars(Main.java:1091)
> jvm 1 | at org.apache.karaf.main.Main.substVars(Main.java:1091)
> jvm 1 | at org.apache.karaf.main.Main.substVars(Main.java:1091)
>   2.2 I need to add the following to start : wrapper.java.classpath.4=%KARAF_HOME%/system/org/apache/felix/org.apache.felix.framework/3.0.1/org.apache.felix.framework-3.0.1.jar
>   2.3 The following line is incorrect : wrapper.app.parameter.1=org.apache.karaf.main.Bootstrap

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message