karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Lilja <mindcoo...@gmail.com>
Subject Re: Consider KARAF-5934 for Karaf 4.2.2?
Date Sun, 02 Dec 2018 20:15:04 GMT
Hi, see my replies at relevant places below!

On 2018-12-02 21:03, Jean-Baptiste Onofré wrote:
> Hi Eric,
>
> The update to maven-bundle-plugin 4.1.0 introduces some other changes 
> (as the requirements/capabilities created are extended). Why do you 
> need this for 4.2.2 ? It's transparent for you as user.
> So I will try but without strong commitment. Reasonably, I would 
> prefer to target in 4.2.3 as I'm planning 4.2.2 for this week. So, it 
> will be a best effort.

Okay, I see, I bumped to that version for my projects without issue so I 
thought it was straight-forward.

>
> Yes, deploy folder is enabled by default. Did you deploy a bundle or a 
> raw jar ?

It was one of my bundles, built using maven-bundle-plugin 4.1.0. I have 
no troubles provisioning it programmatcially when using Karaf/Pax-Exam. 
I also tried with a 3PP found on Maven central. The deploy folder 
doesn't seem to be active on Windows. It was working fine on Windows a 
couple of versions (of Karaf) ago.

>
> The line breaks should be fixed already (you can test on 4.2.2-SNAPSHOT).

Ah, nice to hear! Could you try on your end Windows with TakeCommand to 
see about the question-mark-thingie? I also recall a DOS .bat-file error 
being reported by TakeCommand as I launched karaf.bat

- Eric L

>
> Regards
> JB
>
> On 02/12/2018 20:15, Eric Lilja wrote:
>> Hi, is it possible to consider including KARAF-5934 for 4.2.2? I saw 
>> it was just tentatively postponed to 4.2.3.
>>
>> Also, is the deploy folder enabled by default? I downloaded the 
>> binary distribution (version 4.2.1), and created a new instance with 
>> feature scr enabled. Everything else vanilla. I put a bundle in the 
>> deploy folder but it doesn't get installed, no interesting output 
>> from log:tail either, so no failures. Just like the directory was not 
>> monitored at all (I did use the deploy directory in the instance I 
>> created).
>>
>> Furthermore, output from scr:list seems to lack line breaks. This is 
>> under Windows, with Cygwin (Mintty) as terminal. Also tried with 
>> TakeCommand under Windows, which used to work really well with Karaf, 
>> but when one does bundle:list -s -t 0 for example, a lot columns 
>> contains only ?-characters (question marks). Also scr:list looks bad 
>> under it.
>>
>> - Eric L
>>


Mime
View raw message