karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grzegorz Grzybek <gr.grzy...@gmail.com>
Subject Re: Help to get out of pax-web from karaf distribution
Date Wed, 05 Dec 2018 10:47:57 GMT
Hello

You have 3 choices:
 - feature:uninstall them after startup (they won't be started next time
you run Karaf)
 - ensure there are no such features in etc/org.apache.karaf.features.cfg
 - build your own Karaf distro:
http://karaf.apache.org/manual/latest/#_custom_distributions

btw. I've started minimal 4.2.1 distribution and I don't see pax-web
bundles:

karaf@root()> la -l
START LEVEL 100 , List Threshold: 0
ID │ State    │ Lvl │ Version  │ Location
───┼──────────┼─────┼──────────┼──────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
 0 │ Active   │   0 │ 5.6.10   │ System Bundle
 1 │ Resolved │   1 │ 4.2.1    │
mvn:org.apache.karaf.features/org.apache.karaf.features.extension/4.2.1
 2 │ Active   │   5 │ 2.5.4    │ mvn:org.ops4j.pax.url/pax-url-aether/2.5.4
 3 │ Active   │   8 │ 1.17.1   │ mvn:org.fusesource.jansi/jansi/1.17.1
 4 │ Active   │   8 │ 1.10.1   │
mvn:org.ops4j.pax.logging/pax-logging-api/1.10.1
 5 │ Active   │   8 │ 1.10.1   │
mvn:org.ops4j.pax.logging/pax-logging-log4j2/1.10.1
 6 │ Active   │   9 │ 1.0.2    │
mvn:org.apache.felix/org.apache.felix.coordinator/1.0.2
 7 │ Active   │  10 │ 1.9.4    │
mvn:org.apache.felix/org.apache.felix.configadmin/1.9.4
 8 │ Active   │  11 │ 3.6.4    │
mvn:org.apache.felix/org.apache.felix.fileinstall/3.6.4
 9 │ Active   │  15 │ 4.2.1    │
mvn:org.apache.karaf.features/org.apache.karaf.features.core/4.2.1
10 │ Active   │  20 │ 2.2.11.1 │
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jaxb-impl/2.2.11_1
11 │ Active   │  30 │ 4.2.1    │
mvn:org.apache.karaf.bundle/org.apache.karaf.bundle.core/4.2.1
12 │ Active   │  30 │ 4.2.1    │
mvn:org.apache.karaf.config/org.apache.karaf.config.core/4.2.1
13 │ Active   │  30 │ 4.2.1    │
mvn:org.apache.karaf.features/org.apache.karaf.features.command/4.2.1
14 │ Active   │  30 │ 4.2.1    │
mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.command/4.2.1
15 │ Active   │  30 │ 4.2.1    │
mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.config/4.2.1
16 │ Active   │  30 │ 4.2.1    │
mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.modules/4.2.1
17 │ Active   │  30 │ 4.2.1    │
mvn:org.apache.karaf.log/org.apache.karaf.log.core/4.2.1
18 │ Active   │  30 │ 4.2.1    │
mvn:org.apache.karaf.shell/org.apache.karaf.shell.commands/4.2.1
19 │ Active   │  30 │ 4.2.1    │
mvn:org.apache.karaf.shell/org.apache.karaf.shell.core/4.2.1
20 │ Active   │  30 │ 4.2.1    │
mvn:org.apache.karaf.shell/org.apache.karaf.shell.ssh/4.2.1
21 │ Active   │  30 │ 0.3.11.1 │
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.not-yet-commons-ssl/0.3.11_1
22 │ Active   │  30 │ 1.7.0    │ mvn:org.apache.sshd/sshd-core/1.7.0
23 │ Active   │  30 │ 3.9.0    │ mvn:org.jline/jline-builtins/3.9.0
24 │ Active   │  30 │ 3.9.0    │ mvn:org.jline/jline-reader/3.9.0
25 │ Active   │  30 │ 3.9.0    │ mvn:org.jline/jline-terminal/3.9.0
26 │ Resolved │  30 │ 3.9.0    │ mvn:org.jline/jline-terminal-jansi/3.9.0

regards
Grzegorz Grzybek

śr., 5 gru 2018 o 11:41 Sai Sankar <saisankar.c@motivitylabs.com>
napisał(a):

> Hi All
>
> I dont want Pax-web features to be installed or installable with KARAF
> 4.2.0. Tried Standard and minimal distributions too, but either way it is
> installing pax-web features.
>
> Karaf Version is  : 4.2
>
> pax-web-core                    | 7.0.0            |          | Started
> | org.ops4j.pax.web-7.0.0           | Provide Core pax-web bundles
> pax-jetty                       | 9.4.6.v20170531  |          | Started
> | org.ops4j.pax.web-7.0.0           | Provide Jetty engine support
> pax-jetty-http2                 | 7.0.0            |          | Uninstalled
> | org.ops4j.pax.web-7.0.0           | Optional additional feature to run
> Jetty with SPDY
> pax-http-jetty                  | 7.0.0            |          | Started
> | org.ops4j.pax.web-7.0.0           |
> pax-http                        | 7.0.0            |          | Started
> | org.ops4j.pax.web-7.0.0           | Implementation of the OSGI HTTP
> Service
> pax-http-whiteboard             | 7.0.0            |          | Started
> | org.ops4j.pax.web-7.0.0           | Provide HTTP Whiteboard pattern
> support
> pax-war                         | 7.0.0            |          | Started
> | org.ops4j.pax.web-7.0.0           | Provide support of a full
> WebContainer
> pax-http-tomcat                 | 7.0.0            |          | Uninstalled
> | org.ops4j.pax.web-7.0.0           | Provide Tomcat support
> pax-war-tomcat                  | 7.0.0            |          | Uninstalled
> | org.ops4j.pax.web-7.0.0           |
> pax-jsf-support                 | 7.0.0            |          | Uninstalled
> | org.ops4j.pax.web-7.0.0           |
> pax-jsf-resources-support       | 7.0.0            |          | Uninstalled
> | org.ops4j.pax.web-7.0.0           | Provide sharing of resources
> according
> to Servlet
> undertow                        | 1.4.23.Final     |          | Uninstalled
> | org.ops4j.pax.web-7.0.0           |
> pax-http-undertow               | 7.0.0            |          | Uninstalled
> | org.ops4j.pax.web-7.0.0           |
>
>
> is there any way to skip installing pax-web features in karaf
> -distribution.
>
> Thanks
> Sai
>
>
>
>
>
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message