karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "munishgupta.asr" <munishgupta....@gmail.com>
Subject Re: issues while using Spring 5.0.4 with latest KARAF 4.2.0
Date Tue, 24 Jul 2018 07:19:35 GMT
Hi JB,

I am not sure If i understood your question properly but Here is how I
started using blueprint. Kindly review and suggest. 

Earlier we were using KARAF 4.0.10 and spring 3.1.4 release was getting
installed when spring-dm was installed. Now when I am upgrading to 4.2.0, I
am installing spring feature which is installing spring 5.X.

we are using spring MVC in our web related modules and were using
spring-osgi-web classes to load XMLWebContext in web.xml. it was using
org.springframework.web.context.ContextLoaderListener and 
org.springframework.osgi.web.context.support. 

Now when I had faced problem with 4.2.0, i was updated that spring-dm is not
supported was i was recommended to use blueprint. Guillaume mentioned in one
of the reply that i can use aries-blueprint and it has 99% compatibility
with spring-dm. I was able to see aries-blueprint bundles in feature:list
also so I moved in that direction.

Kindly suggest if I had any way here to get my web part working.

Regards
Munish




--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html

Mime
View raw message