karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: [4.2.0.M1] - Error installing Activemq
Date Sun, 12 Nov 2017 09:48:51 GMT
Yes, probably at least for the transition to the new commands layer.

Regards
JB

On 11/12/2017 10:41 AM, Francois Papon wrote:
> Ok, it work's.
> 
> Thanks
> 
> Did this dependency should be add in the activemq karaf feature in a
> future version ?
> 
> 
> Le 12/11/2017 à 10:29, Jean-Baptiste Onofré a écrit :
>> Hi,
>>
>> you have to install the shell-compat feature to provide felix gogo
>> commands.
>>
>> Regards
>> JB
>>
>> On 11/11/2017 05:58 PM, Francois Papon wrote:
>>> Hi,
>>>
>>> I've got an error when installing activemq feature link to the version
>>> of felix gogo command :
>>>
>>> karaf@root()> feature:install activemq
>>> Error executing command: Unable to resolve root: missing requirement
>>> [root] osgi.identity; osgi.identity=activemq; type=karaf.feature;
>>> version="[5.15.2,5.15.2]";
>>> filter:="(&(osgi.identity=activemq)(type=karaf.feature)(version>=5.15.2)(version<=5.15.2))"
>>>
>>> [caused by: Unable to resolve activemq/5.15.2: missing requirement
>>> [activemq/5.15.2] osgi.identity; osgi.identity=activemq-karaf;
>>> type=osgi.bundle; version="[5.15.2,5.15.2]"; resolution:=mandatory
>>> [caused by: Unable to resolve activemq-karaf/5.15.2: missing requirement
>>> [activemq-karaf/5.15.2] osgi.wiring.package;
>>> filter:="(&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))"]]
>>>
>>>
>>>
>>
> 

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message