karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francois Papon <francois.pa...@openobject.fr>
Subject Re: [4.2.0.M1] - Error installing Activemq
Date Sun, 12 Nov 2017 09:37:15 GMT
Ok, it work's

Thanks

Le 11/11/2017 à 23:11, Guillaume Nodet a écrit :
> You need to install the shell-compat feature along with activemq.
>
> 2017-11-11 17:58 GMT+01:00 Francois Papon <francois.papon@openobject.fr>:
>
>> Hi,
>>
>> I've got an error when installing activemq feature link to the version
>> of felix gogo command :
>>
>> karaf@root()> feature:install activemq
>> Error executing command: Unable to resolve root: missing requirement
>> [root] osgi.identity; osgi.identity=activemq; type=karaf.feature;
>> version="[5.15.2,5.15.2]";
>> filter:="(&(osgi.identity=activemq)(type=karaf.feature)(
>> version>=5.15.2)(version<=5.15.2))"
>> [caused by: Unable to resolve activemq/5.15.2: missing requirement
>> [activemq/5.15.2] osgi.identity; osgi.identity=activemq-karaf;
>> type=osgi.bundle; version="[5.15.2,5.15.2]"; resolution:=mandatory
>> [caused by: Unable to resolve activemq-karaf/5.15.2: missing requirement
>> [activemq-karaf/5.15.2] osgi.wiring.package;
>> filter:="(&(osgi.wiring.package=org.apache.felix.gogo.
>> commands)(version>=0.16.0)(!(version>=1.0.0)))"]]
>>
>>
>>
>


Mime
View raw message