karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kemitix <pcampb...@kemitix.net>
Subject Re: Unit tests and refactoring - karaf-maven-plugin - AssemblyMojo
Date Wed, 12 Apr 2017 18:20:15 GMT
Hi Jean-Baptiste,

Great. Enforcer has requireMavenVersion 3.3.9,4 already so I don't think
it's caring about what dependencies are used within the module. Tooling is
currently using Maven 3.0.3.

Is there a reason to keep the Dependency30Helper class in tooling.utils?
Once the tooling module is upgraded to not use Maven 3.0 is there a reason
why would this class needs to stay? Enforcer appears to already block use by
3.0 on the command line. I've not use Enforcer before, so I may be
misunderstanding what it does.

Dependency31Helper can then be rewritten to use the Maven API directly, as
noted in the javadoc.

If there's no reason to keep the 3.0 helper, I'll delete it rather than
rewriting it to use reflection.

... then I can get back to writing tests for AssemblyMojo. :)

Regard
Paul Campbell



--
View this message in context: http://karaf.922171.n3.nabble.com/Unit-tests-and-refactoring-karaf-maven-plugin-AssemblyMojo-tp4050098p4050111.html
Sent from the Karaf - Dev mailing list archive at Nabble.com.

Mime
View raw message