karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rcbandit <peter.pen...@gmail.com>
Subject missing requirement osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0)))
Date Fri, 26 Aug 2016 21:13:22 GMT
I have a error during Karaf 4.0.5 start. I get this error:

 (version>=1.8.0)(!(version>=2.0.0))) Unresolved requirements:
[[Tracking_Service [11](R 11.0)] osgi.wiring.package;
(&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0)))]
	at
org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)[org.apache.felix.framework-5.4.0.jar:]
	at
org.apache.felix.framework.Felix.startBundle(Felix.java:2117)[org.apache.felix.framework-5.4.0.jar:]
	at
org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)[org.apache.felix.framework-5.4.0.jar:]
	at
org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1253)[4:org.apache.felix.fileinstall:3.5.4]
	at
org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1225)[4:org.apache.felix.fileinstall:3.5.4]
	at
org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:512)[4:org.apache.felix.fileinstall:3.5.4]
	at
org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:361)[4:org.apache.felix.fileinstall:3.5.4]
	at
org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:312) 


Can you give some advice how I can solve this issue?


I use this dependency:

<dependency>
            <groupId>org.osgi</groupId>
            <artifactId>org.osgi.core</artifactId>
            <version>6.0.0</version>
            <type>jar</type>
        </dependency>



--
View this message in context: http://karaf.922171.n3.nabble.com/missing-requirement-osgi-wiring-package-org-osgi-framework-version-1-8-0-version-2-0-0-tp4047719.html
Sent from the Karaf - Dev mailing list archive at Nabble.com.

Mime
View raw message