karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Installing spring-web via feature file brings in multiple versions of spring
Date Tue, 12 Apr 2016 05:14:23 GMT
Assuming the feature use my as inner feature with just 1.0 
<feature><feature version="1.0">my</feature></feature> of course ;)

Regards
JB

On 04/12/2016 06:40 AM, Jean-Baptiste Onofré wrote:
> Correct. However my explanation was: if you install a specific feature
> version my/1.0, and you have a feature doing just my 1.0, then you can
> have 1.0 and 2.0 installed if both are available.
>
> Thanks !
> Regards
> JB
>
> On 04/12/2016 01:03 AM, Guillaume Nodet wrote:
>> Just found this reply.
>>
>> I agree with the first part, i.e. "just one version means this version up
>> to any new version (infinite)", however I tend to disagree with the
>> conclusion.
>> I don't think this should lead to *all* matching features to be
>> installed,
>> but in the simple case, only the highest one should be installed (with no
>> additional constraints).
>> The semantic is : "I depend on a feature named 'spring'", not "I
>> depend on
>> all features named 'spring'".
>>
>> 2016-02-26 16:10 GMT+01:00 Jean-Baptiste Onofré <jb@nanthrax.net>:
>>
>>> It's normal as just one version means this version up to any new version
>>> (infinite).
>>>
>>> If you want to specify an exact version you should use a closed range:
>>> [version,version]
>>>
>>> Regards
>>> JB
>>>
>>>
>>>
>>> Sent from my Samsung device
>>>
>>>
>>> -------- Original message --------
>>> From: Daniel McGreal <d.j.mcgreal@gmail.com>
>>> Date: 26/02/2016 15:45 (GMT+01:00)
>>> To: user@karaf.apache.org
>>> Subject: Installing spring-web via feature file brings in multiple
>>> versions of spring
>>>
>>> Hi Karaf users,
>>>
>>> With the following feature file under K4.0.4 I’m getting multiple (all?)
>>> spring versions installed, which is causing its own set of problems…
>>> However, with the feature:install command, I correctly only get the
>>> version
>>> requested.
>>>
>>> <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
>>> <features xmlns="http://karaf.apache.org/xmlns/features/v1.3.0"
>>> name="edge.feature">
>>>      <feature name="edge.feature" >
>>>          <feature version="3.2.14.RELEASE_1">spring-web</feature>
>>>      </feature>
>>> </features>
>>>
>>>
>>>
>>>
>>> karaf@root()> feature:install -v edge.feature
>>> Adding features: edge.feature/[0,0.0.0]
>>> Changes to perform:
>>>    Region: root
>>>      Bundles to install:
>>>        mvn:javax.mail/mail/1.4.4
>>>        mvn:javax.servlet/javax.servlet-api/3.1.0
>>>        mvn:javax.websocket/javax.websocket-api/1.1
>>>
>>> mvn:org.apache.aries.spifly/org.apache.aries.spifly.dynamic.bundle/1.0.1
>>>        mvn:org.apache.geronimo.specs/geronimo-jaspic_1.0_spec/1.1
>>>        mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
>>>        mvn:org.apache.karaf.http/org.apache.karaf.http.core/4.0.4
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.aopalliance/1.0_6
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-aop/3.2.14.RELEASE_1
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-aop/4.0.7.RELEASE_3
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-aop/4.1.7.RELEASE_2
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-aop/4.2.3.RELEASE_1
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-beans/3.2.14.RELEASE_1
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-beans/4.0.7.RELEASE_3
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-beans/4.1.7.RELEASE_2
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-beans/4.2.3.RELEASE_1
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/3.2.14.RELEASE_1
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/4.0.7.RELEASE_3
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/4.1.7.RELEASE_2
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/4.2.3.RELEASE_1
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/3.2.14.RELEASE_1
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/4.0.7.RELEASE_3
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/4.1.7.RELEASE_2
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/4.2.3.RELEASE_1
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/3.2.14.RELEASE_1
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/4.0.7.RELEASE_3
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/4.1.7.RELEASE_2
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/4.2.3.RELEASE_1
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-expression/3.2.14.RELEASE_1
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-expression/4.0.7.RELEASE_3
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-expression/4.1.7.RELEASE_2
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-expression/4.2.3.RELEASE_1
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-web/3.2.14.RELEASE_1
>>>
>>>
>>> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-webmvc/3.2.14.RELEASE_1
>>>
>>> … etc
>>>
>>>
>>>
>>>
>>> Any ideas?
>>> Thanks, Dan.
>>>
>>>
>>>
>>
>>
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message