karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From developm...@mobigov.com
Subject Re: Unresolved requirements: [[custom_jar [12](R 12.0)] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))]
Date Thu, 30 Jul 2015 18:42:14 GMT
 

You will probably need to say what version of karaf you are using and
what version you are including in your dependencies when you build.
Example is karaf 4.0.0 

<dependency> 
<groupId>org.apache.felix</groupId> 
<artifactId>org.apache.felix.framework</artifactId> 
<version>5.0.1</version> 
<scope>provided</scope> 
</dependency> 

I think this error comes from building the custom jar with a dependency
with a different version of the osgi framework. 

On 2015-07-30 13:40, rcbandit wrote: 

> Can you give some advice?
> 
> --
> View this message in context: http://karaf.922171.n3.nabble.com/Unresolved-requirements-custom-jar-12-R-12-0-osgi-wiring-package-osgi-wiring-package-org-osgi-framew-tp4041134p4041735.html
[1]
> Sent from the Karaf - Dev mailing list archive at Nabble.com.
 

Links:
------
[1]
http://karaf.922171.n3.nabble.com/Unresolved-requirements-custom-jar-12-R-12-0-osgi-wiring-package-osgi-wiring-package-org-osgi-framew-tp4041134p4041735.html
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message