karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Problem With karaf-maven-plugin V 4.0.0.M2
Date Mon, 25 May 2015 16:25:23 GMT
Hi,

It's something that I saw last week too: the SNAPSHOT dependencies are 
not resolved. I would try with <repository/> with Apache Snapshot repo.

Regards
JB

On 05/25/2015 11:39 AM, Noushad Ali wrote:
> Hi,
> When I try to generate feature.xml file for Karaf 4.0.0.M2, it throws the
> following error.
>
> [INFO] Scanning for projects...
> Downloading:
> http://repo.maven.apache.org/maven2/org/apache/karaf/tooling/karaf-maven-plugin/4.0.0.M2/karaf-maven-plugin-4.0.0.M2.pom
> Downloaded:
> http://repo.maven.apache.org/maven2/org/apache/karaf/tooling/karaf-maven-plugin/4.0.0.M2/karaf-maven-plugin-4.0.0.M2.pom
> (10 KB at 9.2 KB/sec)
> Downloading:
> http://repo.maven.apache.org/maven2/org/apache/karaf/tooling/tooling/4.0.0.M2/tooling-4.0.0.M2.pom
> Downloaded:
> http://repo.maven.apache.org/maven2/org/apache/karaf/tooling/tooling/4.0.0.M2/tooling-4.0.0.M2.pom
> (2 KB at 3.3 KB/sec)
> [WARNING] The POM for
> org.apache.felix:org.apache.felix.utils:jar:1.6.1-SNAPSHOT is missing, no
> dependency information available
> [WARNING] The POM for
> org.apache.felix:org.apache.felix.fileinstall:jar:3.4.3-SNAPSHOT is
> missing, no dependency information available
> Downloading:
> http://repo.maven.apache.org/maven2/org/apache/karaf/tooling/karaf-maven-plugin/4.0.0.M2/karaf-maven-plugin-4.0.0.M2.jar
> Downloaded:
> http://repo.maven.apache.org/maven2/org/apache/karaf/tooling/karaf-maven-plugin/4.0.0.M2/karaf-maven-plugin-4.0.0.M2.jar
> (186 KB at 118.3 KB/sec)
> [ERROR] The build could not read 1 project -> [Help 1]
> [ERROR]
> [ERROR]   The project com.company.product.proxy:wap-push-tracker:1.0
> (/home/noushad/git/product/product/product-proxy/wap-push-tracker/pom.xml)
> has 2 errors
> [ERROR]     Unresolveable build extension: Plugin
> org.apache.karaf.tooling:karaf-maven-plugin:4.0.0.M2 or one of its
> dependencies could not be resolved: The following artifacts could not be
> resolved: org.apache.felix:org.apache.felix.utils:jar:1.6.1-SNAPSHOT,
> org.apache.felix:org.apache.felix.fileinstall:jar:3.4.3-SNAPSHOT: Could not
> find artifact org.apache.felix:org.apache.felix.utils:jar:1.6.1-SNAPSHOT ->
> [Help 2]
> [ERROR]     Unknown packaging: bundle @ line 12, column 13
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e
> switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
> [ERROR] [Help 2]
> http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
>
>
> Possible Cause(s):
> 1. The org.apache.karaf.tooling/karaf-maven-plugin/4.0.0.M2 s POM refers to
> SNAPSHOT versions of artifacts ,
> org.apache.felix/org.apache.felix.XXX/version.SNAPSHOT   which are
> currently not available at maven central
>
>
>
>
> Somebody please correct this,
>
>
> Thanks and Regards,
>
> Noushad Ali
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message