karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Achim Nierbeck <bcanh...@googlemail.com>
Subject Karaf 4.0 switch to Java8?
Date Mon, 26 Jan 2015 15:22:13 GMT
Hi,

How is everybody feeling about to switch to JDK8 for building the master
branch? (Karaf 4)
According to [1], Java 7 is pretty much at EOL.
I think this needs to be addressed right now since for Pax Web 4.1. which
is now used by Karaf 4
it is needed to use JDK8. Not because of using any new features of Java 8
but because of the memory issues while running the integration tests.
There seems to be a reproducible issue since switching to Jetty 9.2 and
running the integration tests with Java 7. Those are gone when Java 8 is
used.
Therefore Pax Web 4.1. uses JDK8 for building right now, though the
switches are set to be compatible with Java 7, for source and target.

Another benefit might be to use JDK8 features already.

For me I would like to see at least JDK8 with source and target set to 7

regards, Achim

[1] - http://www.oracle.com/technetwork/java/eol-135779.html

-- 

Apache Member
Apache Karaf <http://karaf.apache.org/> Committer & PMC
OPS4J Pax Web <http://wiki.ops4j.org/display/paxweb/Pax+Web/> Committer &
Project Lead
blog <http://notizblog.nierbeck.de/>
Co-Author of Apache Karaf Cookbook <http://bit.ly/1ps9rkS>

Software Architect / Project Manager / Scrum Master

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message