karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: [VOTE] Apache Karaf Cellar 3.0.1 release
Date Wed, 21 Jan 2015 08:10:32 GMT
Yes, but previously we use both: multicast AND tcp-ip. So even if it 
didn't work in multicast, it uses tcp-ip. So maybe your interface never 
worked with multicast ;)
Now, this config is no more possible: it's multicast OR tcp-ip.

Can you test the tcp-ip config ?

Regards
JB

On 01/21/2015 09:05 AM, Achim Nierbeck wrote:
> Strange, I didn't change anything on my Mac network interface. So we need
> to file a bug at hazelcast then?
>
> Regards, Achim
>
> sent from mobile device
> Am 21.01.2015 09:02 schrieb "Jean-Baptiste Onofré" <jb@nanthrax.net>:
>
>> yes and no: it's a change in Hazelcast. So what would you propose:
>> 1/ disabling multicast and enable tcp-ip: in that case, it's a regression
>> for user using multicast on different machines. It will work in your case
>> for node on a single machine without multicast support on the interface (by
>> the way, it's the config used in hazelcast module tests as the tests run on
>> a single machine)
>> 2/ enabling multicast and disable tcp-ip: it's the current case, it works
>> for users on different machines using multicast, not when multicast is not
>> allowed.
>>
>> So ...
>>
>> I would prefer the current situation (which works if your network
>> interface supports multicast).
>>
>> Regards
>> JB
>>
>> On 01/21/2015 08:51 AM, Achim Nierbeck wrote:
>>
>>> Hi,
>>> As it used to work without this tweak before it's still a regression. :-)
>>>
>>> Regards, Achim
>>>
>>> sent from mobile device
>>> Am 21.01.2015 07:36 schrieb "Jean-Baptiste Onofré" <jb@nanthrax.net>:
>>>
>>>   It seems that I reproduce the same behavior by disable promisc/multicast
>>>> on my network interface. Just disabling multicast and enabling tcp-ip in
>>>> etc/hazelcast.xml fixes the problem.
>>>>
>>>> Regards
>>>> JB
>>>>
>>>> On 01/21/2015 07:21 AM, Jean-Baptiste Onofré wrote:
>>>>
>>>>   Ahhhh I may know.
>>>>>
>>>>> In previous Hazelcast version, it was possible to enable multicast AND
>>>>> tcp-ip for joining. Since Hazelcast 3.3.x, it's no more possible.
>>>>> By default, in the Cellar etc/hazelcast.xml, I enabled multicast and
>>>>> disable tcp-ip.
>>>>>
>>>>> If your interface or network doesn't support multicast, it will fail
to
>>>>> discover the nodes.
>>>>>
>>>>> Can you try to change to tcp-ip (with localhost) instead of multicast
?
>>>>>
>>>>> Thanks,
>>>>> Regards
>>>>> JB
>>>>>
>>>>> On 01/21/2015 12:15 AM, Achim Nierbeck wrote:
>>>>>
>>>>>   Config seed port is 5701 and cluster size is 1. Some of the ports seem
>>>>>> occupied!
>>>>>>
>>>>>>
>>>>>
>>>>>   --
>>>> Jean-Baptiste Onofré
>>>> jbonofre@apache.org
>>>> http://blog.nanthrax.net
>>>> Talend - http://www.talend.com
>>>>
>>>>
>>>
>> --
>> Jean-Baptiste Onofré
>> jbonofre@apache.org
>> http://blog.nanthrax.net
>> Talend - http://www.talend.com
>>
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message