karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject RE: Wrong Dependencies for Pax-CDI-Web in Karaf 4.0.0.M1?
Date Sun, 23 Nov 2014 17:38:21 GMT
Yes it's an issue introduced by a commit. The guy said that he gonna fix it but he didn't for
now. I will review and fix or revert.

Regards
JB


Sent from my Samsung Galaxy smartphone.


-------- Original message --------
From: Templarthelast <leichler@maredit.de> 
Date:23/11/2014  11:57  (GMT+01:00) 
To: dev@karaf.apache.org 
Cc:  
Subject: Wrong Dependencies for Pax-CDI-Web in Karaf 4.0.0.M1? 

Hi,

I started using Karaf by downloading Karaf 4.0.0.M1 from the Karaf site and
wanted to install the pax-web-feature but I got the error: 

Error executing command: Unable to resolve root: missing requirement [root]
osgi.identity; osgi.identity=pax-cdi-web; type=karaf.feature;
version="[0.8.0,0.8.0]";
filter:="(&(osgi.identity=pax-cdi-web)(type=karaf.feature)(version>=0.8.0)(version<=0.8.0))"
[caused by: Unable to resolve pax-cdi-web/0.8.0: missing requirement
[pax-cdi-web/0.8.0] osgi.identity; osgi.identity=org.ops4j.pax.cdi.web;
type=osgi.bundle; version="[0.8.0,0.8.0]"; resolution:=mandatory [caused by:
Unable to resolve org.ops4j.pax.cdi.web/0.8.0: missing requirement
[org.ops4j.pax.cdi.web/0.8.0] osgi.wiring.package;
filter:="(&(osgi.wiring.package=org.ops4j.pax.web.service)(version>=3.0.0)(!(version>=4.0.0)))“]]

It seems like the 0.8 Version of Pax-CDI-Web needs Pax-Web-Api with a
Version >=3.0.0 and not >=4.0.0 but the Version installed by the
Pax-War-Tomcat or Pax-Http is 4.0 .

Is this a bug or do I need an additional Step to get this working?

best regards,

Lukas



--
View this message in context: http://karaf.922171.n3.nabble.com/Wrong-Dependencies-for-Pax-CDI-Web-in-Karaf-4-0-0-M1-tp4036607.html
Sent from the Karaf - Dev mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message