karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christoph Gritschenberger <christoph.gritschenber...@gmail.com>
Subject Re: javax.annotation 1.2.0 and KARAF-2660
Date Mon, 27 Oct 2014 08:39:32 GMT
Actually all Java SE versions lack the "java.annotation.ManagedBean"
that was added in 1.1.

I now changed the versions to 1.0 for JRE 6, 7, and 8.

I applied the fix to master and karaf-3.0.x

kind regards,
Christoph

On 23/10/14 11:56, jsnharris wrote:
> I changed the javax.annotation version in the etc/jre.properties to 1.1 and
> then added the javax.annotation 1.2 bundle to my Karaf installation and the
> annotation I need is accessed correctly. If the 1.1 versions are still
> available for other bundles to use and as 1.1 is in SE, this would appear to
> be the correct way forward (assuming EE versions are not to be part of
> standard JRE Karaf settings) 
> 
> 
> 
> --
> View this message in context: http://karaf.922171.n3.nabble.com/javax-annotation-1-2-0-and-KARAF-2660-tp4036056p4036090.html
> Sent from the Karaf - Dev mailing list archive at Nabble.com.
> 



Mime
View raw message