karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Karaf 3,4 plans?
Date Fri, 20 Jun 2014 12:09:36 GMT
Hi Guillaume,

I have no problem to release 2.4.0, but it means that we have to release 
some dependency projects (aries especially) quickly.

Let me help on that.

Regards
JB

On 06/20/2014 02:07 PM, Guillaume Nodet wrote:
> 2014-06-20 11:01 GMT+02:00 Jean-Baptiste Onofré <jb@nanthrax.net>:
>
>> Hi Benjamin,
>>
>> If you follow the discussion on the dev mailing list, I think the release
>> plan is well defined.
>> More over on the website you have the dependency matrix.
>>
>> We maintain two maintenance release branches:
>>
>> 1/ 2.3.x is "previous" maintenance release
>> 2/ 3.0.x is "current" maintenance release
>> 3/ 4.0.0 is future (where we do the refactoring, etc, it would not be
>> released before September).
>> 4/ 2.x (2.4.x) is "transition" branch between 2.3.x and 3.0.x. Not sure it
>> would make much sense to release it now (I would encourage users to jump
>> from 2.3.x to 3.0.x). So no plan for now about a release.
>> That's why I didn't talk about 2.4 in my previous e-mail.
>>
>
> Well, I actually need this release asap.  Users can quite safely migrate
> from 2.3.x to 2.4.x, but switching to 3.0.x is a much bigger change with
> lots of incompatibilites.  So users in need for OSGi r5 would really
> benefit from it.
> I'm planning for a 2.4.0 release as soon as the snapshot dependencies can
> be resolved.
>
>
>>
>> I will add a page on the website to add this plan:
>> https://issues.apache.org/jira/browse/KARAF-3060
>>
>> I will do that in a couple of minutes.
>>
>> Regards
>> JB
>>
>>
>> On 06/20/2014 10:37 AM, Benjamin Graf wrote:
>>
>>> Hi,
>>>
>>> I think this discussion shows that karaf needs an actual release and
>>> maintenance plan. Don't forget we still have 2.3.x and 2.x branch used
>>> and developed. 2.4 will be an OSGi r5 release too. Well, that's really
>>> confusing. ;-)
>>>
>>> Regards
>>> Benjamin
>>>
>>> On 19. Juni 2014 21:24:53 MESZ, "Jean-Baptiste Onofré" <jb@nanthrax.net>
>>> wrote:
>>>
>>>      Hi Scott,
>>>
>>>      to be clear, this is the current situation:
>>>
>>>      Karaf 3.0.1 (latest release): Felix 4.2.1/Equinox 3.8.2, OSGi r4.3
>>> (and
>>>      partial r5 support)
>>>      Karaf 3.0.2 (next release, planned in a couple of weeks): Felix
>>>      4.4.0/Equinox 3.9.1, OSGi r5
>>>      Karaf 4.0.0 (future): Felix 4.4.0/Equinox 3.9.1, OSGi r5
>>>
>>>      Regards
>>>      JB
>>>
>>>      On 06/19/2014 08:27 PM, Scott Lewis wrote:
>>>
>>>          On 6/19/2014 1:59 AM, Jean-Baptiste Onofré wrote:
>>>
>>>              Yes, it is but not yet released (it will be included in
>>>              3.0.2). I
>>>              talked about the current version in 3.0.1 (latest release).
>>>
>>>
>>>          I'm a little confused about framework versions and Karaf version.
>>>
>>>          Is the conclusion that 3.0.1 (latest release) does not have the
>>>          Felix
>>>          version that supports OSGi R5? But some version of Felix that
>>>          supports
>>>          R5 will be included in Karaf 3.0.2?
>>>
>>>          If that's right:
>>>
>>>          1) When is Karaf 3.0.2 to be expected?
>>>          2) Which version of Felix will be included in 3.0.2?
>>>
>>>          Thanksinadvance,
>>>
>>>          Scott
>>>
>>>
>>>
>>>
>>> --
>>> Diese Nachricht wurde von meinem Android-Mobiltelefon mit K-9 Mail
>>> gesendet.
>>>
>>
>> --
>> Jean-Baptiste Onofré
>> jbonofre@apache.org
>> http://blog.nanthrax.net
>> Talend - http://www.talend.com
>>
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message