karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajbir Saini <rajbsa...@yahoo.com.INVALID>
Subject Re: Missing Constraint: Import-Package: com.sun.jersey.api.client
Date Tue, 17 Jun 2014 07:14:16 GMT
Try removing the version numbers from imported packages. It may be 
version in your development environment are not the same in Karaf.

On Tuesday 17 June 2014 12:39 PM, SapnaB wrote:
> Did that too.. Uninstalled all the jersey jars I had deployed earlier on
> Karaf, and re-deployed using the wrap command. Also re-installed my bundle..
> but the problem still exists.
>
> I wish Karaf gave more explanatory error messages. I really cant find
> anything to resolve this exception :(
>
> Unable to start bundle 402: The bundle "Test_0.0.1.SNAPSHOT [402]" could not
> be resolved. Reason: Missing Constraint: Import-Package:
> com.sun.jersey.api.client; version="[1.18.0,2.0.0)"
>
>
>
> --
> View this message in context: http://karaf.922171.n3.nabble.com/Missing-Constraint-Import-Package-com-sun-jersey-api-client-tp4033550p4033565.html
> Sent from the Karaf - Dev mailing list archive at Nabble.com.
>


Mime
View raw message