karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Problem with PAX CDI features in custom distribution
Date Tue, 18 Feb 2014 19:56:07 GMT
Basically, it's a mistake in the feature, as the version is not set for 
jpa spec bundle.

I'm fixing that on CDI side.

Thanks for the report.

Regards
JB

On 02/18/2014 08:10 PM, Krzysztof Sobkowiak wrote:
> Hi
>
> I'm trying to upgrade the current code of ServiceMix 5 to Karaf
> 3.3.5-SNAPSHOT (2.3.4 fails due to the problem with hibernate-envers
> feature) but I get following error while building the full assembly.
>
> [INFO] Apache ServiceMix :: Assemblies :: Apache ServiceMix  SUCCESS
> [39.482s]
> [INFO] Apache ServiceMix :: Assemblies :: Apache ServiceMix (Minimal)
> SUCCESS [28.979s]
> [INFO] Apache ServiceMix :: Assemblies :: Apache ServiceMix (Full)
> FAILURE [4.834s]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 1:15.916s
> [INFO] Finished at: Tue Feb 18 19:48:35 CET 2014
> [INFO] Final Memory: 32M/645M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal
> org.apache.karaf.tooling:features-maven-plugin:2.3.5-SNAPSHOT:add-features-to-repo
> (add-features-to-repo) on project apache-servicemix-full: Cannot find
> version for: org.apache.geronimo.specs/geronimo-jpa_2.0_spec/ -> [Help 1]
>
> I think this is caused by one of pax cdi features referenced by Karaf
> enterprise features which includes the geronimo-jpa_2.0_spec bundle with
> no version.
>
>   <feature name="pax-cdi-deltaspike-jpa" description="Apche Deltaspike
> jpa support" version="0.5" resolver="(obr)">
>      <feature version=">0.5">pax-cdi-deltaspike-core</feature>
> <bundle>mvn:org.ops4j.base/ops4j-base-monitors/1.4.0</bundle>
> <bundle>mvn:org.ops4j.base/ops4j-base-io/1.4.0</bundle>
> <bundle>mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1</bundle>
> *<bundle>mvn:org.apache.geronimo.specs/geronimo-jpa_2.0_spec/</bundle>*
>      <bundle>mvn:org.ops4j.pax.jpa/pax-jpa/0.1.1</bundle>
> <bundle>mvn:org.ops4j.pax.jdbc/pax-jdbc/0.3.0</bundle>
> <bundle>mvn:org.apache.deltaspike.modules/deltaspike-jpa-module-api/0.5</bundle>
>
> <bundle>mvn:org.apache.deltaspike.modules/deltaspike-jpa-module-impl/0.5</bundle>
>
> <bundle>mvn:org.ops4j.pax.cdi.fragment/pax-cdi-fragment-ds-jpa/0.6.0</bundle>
>
>    </feature>
>
> I'm writing this mail on this list because I think this feature can
> cause problems with other custom distributions based on the Karaf
> releases including this features repository.
>
> Regards
> Krzysztof
>
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message