karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: Problems with new maven version
Date Wed, 21 Aug 2013 12:53:39 GMT

On Aug 21, 2013, at 8:36 AM, Andreas Pieber <anpieber@gmail.com> wrote:

> Hey guys,
> 
> I've kind of a problem with KARAF-2395 [1]. While I've a patch making
> everything compatible to maven 3.1.x it's incompatible then to maven 3.0.x.
> Thanks to the way we're using aether the only real option I see is to
> either set the minimum maven version to 3.1 or provide two commands; one
> for 3.0 and one for 3.1. Both solutions don't feel ideal for me. Any
> ideas/proposals how to progress?


I guess my suggestion would be to look at the source for the maven-dependency-plugin to see
how it's handling some of this.   I don't think there is much that Karaf does that the dependency
plugin  doesn't do something very similar to (copying artifacts, resolving tree's, etc..).
   Since the latest dependency plugin works with both versions of Maven, there should be a
way.

Dan



> 
> Kind regards,
> Andreas
> 
> [1]https://issues.apache.org/jira/browse/KARAF-2395

-- 
Daniel Kulp
dkulp@apache.org - http://dankulp.com/blog
Talend Community Coder - http://coders.talend.com


Mime
View raw message