karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jb@nanthrax.net" ...@nanthrax.net>
Subject Re: Karaf 2.3.x and Karaf 3.0.x support ASM in Version 4.1, why?
Date Mon, 21 Jan 2013 17:00:20 GMT
It was a requirement for Aries Proxy update.

Regards
JB

--
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://wwx.talend.com

----- Reply message -----
From: "Achim Nierbeck" <bcanhome@googlemail.com>
To: <dev@karaf.apache.org>
Subject: Karaf 2.3.x and Karaf 3.0.x support ASM in Version 4.1, why?
Date: Mon, Jan 21, 2013 6:12 am


Hi guys,

anyone know why we moved to version 4.1 of ASM in Karaf 2.3 and 3.0?
Cause this is an issue for Pax-Web right now (at least if working with
xbean-finder) and surely will also be an issue for Aries Annotation
support.
To my knowledge the Aries Annotation scanner also uses xbean-finder in
version 3.x which needs ASM 3.1 and not 4.x.
If needed we gonna need to raise an issue at the xbean project to tighten
the range for ASM to [3.1, 4.0)


regards, Achim

-- 

Apache Karaf <http://karaf.apache.org/> Committer & PMC
OPS4J Pax Web <http://wiki.ops4j.org/display/paxweb/Pax+Web/> Committer &
Project Lead
OPS4J Pax for Vaadin <http://team.ops4j.org/wiki/display/PAXVAADIN/Home>
Commiter & Project Lead
blog <http://notizblog.nierbeck.de/>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message