karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Pieber <anpie...@gmail.com>
Subject Re: [DISCUSSION] OSGi core version in Karaf version
Date Sat, 18 Aug 2012 08:59:26 GMT
I've no problem with either of those since the 4.3 release of the core
does not break backward compatibility (compared to 5.0) --> also fine
with that approach (BUT, AFAIK 2.3.x had been ported to 4.3 already)

Kind regards,
Andreas

On Sat, Aug 18, 2012 at 9:53 AM, Ioannis Canellos <iocanel@gmail.com> wrote:
> I like Andreas first proposal but with a minor change:
>
> - Karaf 2.2.x => OSGi core 4.2.0
>> - Karaf 2.3.x => OSGi core 4.2.0 (at some point we need to deliver new
>> features, without changing the world. For 4.3.0 in the 2.x branches maybe
>> we could have a 2.4.x, 2.5.x version of Karaf)
>>
>  - Karaf 3.x.y => OSGi core 4.3.0
>> - Karaf 4.x.y => OSGi core 5.0.0
>>
>
>
> --
> *Ioannis Canellos*
> *
> FuseSource <http://fusesource.com>
>
> **
> Blog: http://iocanel.blogspot.com
> **
> Twitter: iocanel
> *

Mime
View raw message