karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Build error on Karaf Trunk - missing dependency
Date Tue, 24 Jul 2012 13:44:42 GMT
Hi Scott,

you can update your local copy, I'm upgrading to Aries Application API 
and Utils 1.0.0 (released).

Regards
JB

On 07/24/2012 03:42 PM, Scott England-Sullivan wrote:
> I just did a checkout and build and am receiving the following error:
> [ERROR] Failed to execute goal on project enterprise: Could not resolve
> dependencies for project
> org.apache.karaf.features:enterprise:pom:3.0.0-SNAPSHOT: The following
> artifacts could not be resolved:
> org.apache.aries.application:org.apache.aries.application.api:jar:1.0.0-SNAPSHOT,
> org.apache.aries.application:org.apache.aries.application.utils:jar:1.0.0-SNAPSHOT
>
> I looked in the Apache snapshot repository and there isn't a 1.0.0-SNAPSHOT
> jar.  Nor is there a 1.0.1-SNAPSHOT.
>
> Side note: I checked out the Aries project and it fails to build due to
> dozens of compile errors.
>
> On Tue, Jul 24, 2012 at 1:17 AM, Jean-Baptiste Onofré <jb@nanthrax.net>wrote:
>
>> FYI,
>>
>> this issue is fixed, someone made a mistake: Aries Blueprint Core trunk is
>> 1.0.1-SNAPSHOT but Aries Blueprint Core Compatibility trunk is still
>> 1.0.0-SNAPSHOT.
>>
>> Regards
>> JB
>>
>>
>> On 07/23/2012 07:29 PM, uromahn wrote:
>>
>>> Hi All,
>>>
>>> I am trying to build my own local snapshot of Karaf 3.0.0 but the build is
>>> failing.
>>>
>>>
>>> [ERROR] Failed to execute goal on project framework: Could not resolve
>>> dependencies for project
>>> org.apache.karaf.features:**framework:pom:3.0.0-SNAPSHOT: Could not find
>>> artifact
>>> org.apache.aries.blueprint:**org.apache.aries.blueprint.**
>>> core.compatibility:jar:1.0.1-**SNAPSHOT
>>> in nexus-local (http://localhost:8081/nexus/**content/groups/public<http://localhost:8081/nexus/content/groups/public>)
>>> -> [Help
>>> 1]
>>>
>>> The version of the Aries Blueprint core-compatibility is defined as
>>> 1.0.1-SNAPSHOT but that version is nowhere to be found - not even in the
>>> publicly available sources of Aries (aka Apache SVN)!
>>>
>>> Can anyone please enlighten me where I should find this version so I can
>>> add
>>> it to my local Nexus? Or should this really be version 1.0.0-SNAPSHOT and
>>> is
>>> actually a bug?
>>>
>>> Thank you,
>>> -Uli
>>>
>>>
>>>
>>> --
>>> View this message in context: http://karaf.922171.n3.nabble.**
>>> com/Build-error-on-Karaf-**Trunk-missing-dependency-**tp4025284.html<http://karaf.922171.n3.nabble.com/Build-error-on-Karaf-Trunk-missing-dependency-tp4025284.html>
>>>
>>> Sent from the Karaf - Dev mailing list archive at Nabble.com.
>>>
>>>
>> --
>> Jean-Baptiste Onofré
>> jbonofre@apache.org
>> http://blog.nanthrax.net
>> Talend - http://www.talend.com
>>
>
>
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message