karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Pieber <anpie...@gmail.com>
Subject Re: [PROPOSAL] New Karaf commands norm
Date Tue, 18 Oct 2011 10:18:40 GMT
My comment on the rename of the admin service could be applied here too; I
think it makes sense to be consistent here and if we don't risk to setup
some existing users we could never evolve and will stuck forever with old
stuff :-(

Kind regards,
Andreas

On Tue, Oct 18, 2011 at 12:14, Jean-Baptiste Onofré <jb@nanthrax.net> wrote:

> Hi all,
>
> in order to be consistent, I would like to apply the same "norm" for all
> Karaf commands.
>
> I propose the following:
>
> 1/ all command scope should be singular (features:* become feature:*,
> bundles:* become bundle:*)
> 2/ command name separator is -. For instance, config:propdel become
> config:prop-del
> 3/ "fine grained commands" should be respect the command-action format. For
> instance, features:addUrl become feature:url-add, feature:url-list
>
> WDYT ?
>
> Regards
> JB
> --
> Jean-Baptiste Onofré
> jbonofre@apache.org
> http://blog.nanthrax.net
> Talend - http://www.talend.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message