karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Achim Nierbeck <bcanh...@googlemail.com>
Subject Re: [PROPOSAL] Features autostart attribute
Date Wed, 12 Oct 2011 12:06:40 GMT
guys, what happened to KISS here?

this is kinda tricky and for me it's just a bit to much :)

regards, Achim

2011/10/12 Jean-Baptiste Onofré <jb@nanthrax.net>

> Hi Dan,
>
> in that case, we could "respin" the feature trigger concept.
> The feature triggers allow you some Karaf scripting after a feature
> installation.
>
> And we would be able to have something like:
>
> <feature name="xx" version="yy">
>  <bundle>...</bundle>
>  <feature version="bb">BB</feature>
>  <trigger phase="post">
> if (${Java.Version})=7
>  feature:install xx/yy
>
> echo "Features Installed"
>  </trigger>
> </feature>
>
> WDYT ?
>
> Regards
> JB
>
>
> On 10/12/2011 01:59 PM, Daniel Kulp wrote:
>
>>
>> Would it make more sense to have something a bit more extensible than an
>> attribute?   For example, I had some bundles I wanted installed on an IBM
>> JDK,
>> but not on a Sun JDK.    Also, JDK 7 vs 6 differences and such can also
>> come
>> into play.   I'm kind of thinking something similar to the Maven profile
>> activation element things, but make it actually work.  :-)     We could
>> add
>> <and>  and<or>  elements and such in there.
>>
>> Either that or define a simple DSL for the attribute
>> install="${Java.Version}=7" etc....
>>
>>
>>
>> Dan
>>
>>
>>
>>
>> On Wednesday, October 12, 2011 12:13:23 PM Jean-Baptiste Onofré wrote:
>>
>>> I also prefer a feature attribute.
>>> Guillaume just mentioned that it means it's "built-in" the feature, and
>>> don't let the user choose its behavior.
>>>
>>> Regarding the attribute name, install="auto" or install="manual" looks
>>> good to me.
>>>
>>> Regards
>>> JB
>>>
>>> On 10/12/2011 12:10 PM, Ioannis Canellos wrote:
>>>
>>>> I would prefer an attribute in the feature descriptor, as it would
>>>> provide more granularity for custom features.
>>>> We may need to rethink the name of the attribute to avoid confusing our
>>>> users.
>>>>
>>>> maybe call it manual="true/false" or deploy="auto/manual"
>>>>
>>>
> --
> Jean-Baptiste Onofré
> jbonofre@apache.org
> http://blog.nanthrax.net
> Talend - http://www.talend.com
>



-- 
--
*Achim Nierbeck*


Apache Karaf <http://karaf.apache.org/> Committer & PMC
OPS4J Pax Web <http://wiki.ops4j.org/display/paxweb/Pax+Web/>  Committer &
Project Lead
blog <http://notizblog.nierbeck.de/>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message