karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Another issue with 2.2.4....
Date Wed, 12 Oct 2011 20:40:22 GMT
Thanks Dan.

FYI, this issue is present in Karaf 2.2.3, 2.2.2, 2.2.1.

The only "correct" version is Karaf 2.2.0 which use Pax Web 1.0.1.

So it's an "old" issue :/

As Dan said, I will take a look tomorrow morning (and eventually release 
a new version of Pax Web).

If it takes time to fix that, or if the impact is too important, I would 
just release note that war feature is Java 6 compliant only and release 
Karaf 2.2.4 as it is.

Regards
JB

On 10/12/2011 10:35 PM, Daniel Kulp wrote:
>
> While doing some testing with 2.2.4-SNAPSHOT, I ran into another issue.  The
> "war" feature no longer supports Java 5.  You cannot install the feature due
> to pax-web-jsp pulling in classes only available in Java6.     Since 2.2.x is
> supposed to support Java5, this is an issue for me.
>
> https://issues.apache.org/jira/browse/KARAF-933
>
>
> JB is going to look a bit at pax-web tomorrow morning to see if there is
> anything that can be done.   If not, we may need to do something like:
>
> 1) release note that war is Java6 only.    (btw: this issue exists in 2.2.3 as
> well)
>
> 2) Remove jsp from the war feature and maybe add a "war-jsp" feature that
> would include it.  (or something similar)
>
> 3) Rollback to pax-web-jsp 1.0.1 (last version that doesn't have the problem)
>
> 4)  others?
>
>
> Anyway, at this point, I'd like to wait and see what JB finds out.
>
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message