karaf-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: karaf-decanter-master » Apache Karaf :: Decanter :: Backend :: Elasticsearch 6.x #951
Date Thu, 23 May 2019 09:32:43 GMT
See <https://builds.apache.org/job/karaf-decanter-master/org.apache.karaf.decanter$org.apache.karaf.decanter.elasticsearch-6.x/951/display/redirect>

------------------------------------------
[INFO] 
[INFO] --< org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x >--
[INFO] Building Apache Karaf :: Decanter :: Backend :: Elasticsearch 6.x 2.3.0-SNAPSHOT [65/75]
[INFO] -------------------------------[ bundle ]-------------------------------
[INFO] 
[INFO] --- maven-clean-plugin:3.1.0:clean (default-clean) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] Deleting <https://builds.apache.org/job/karaf-decanter-master/org.apache.karaf.decanter$org.apache.karaf.decanter.elasticsearch-6.x/ws/target>
[INFO] 
[INFO] --- maven-enforcer-plugin:1.4.1:enforce (enforce-maven-version) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] 
[INFO] --- maven-antrun-plugin:1.8:run (copy-notice) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] Executing tasks

main:
     [copy] Warning: Could not find file <https://builds.apache.org/job/karaf-decanter-master/org.apache.karaf.decanter$org.apache.karaf.decanter.elasticsearch-6.x/ws/NOTICE>
to copy.
[INFO] Executed tasks
[INFO] 
[INFO] --- maven-remote-resources-plugin:1.5:process (process-resource-bundles) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] 
[INFO] --- maven-remote-resources-plugin:1.5:process (default) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] 
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 3 resources
[INFO] Copying 3 resources
[INFO] Copying 3 resources
[INFO] 
[INFO] --- maven-compiler-plugin:3.7.0:compile (default-compile) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 2 source files to <https://builds.apache.org/job/karaf-decanter-master/org.apache.karaf.decanter$org.apache.karaf.decanter.elasticsearch-6.x/ws/target/classes>
[INFO] <https://builds.apache.org/job/karaf-decanter-master/org.apache.karaf.decanter$org.apache.karaf.decanter.elasticsearch-6.x/ws/src/main/java/org/apache/karaf/decanter/elasticsearch/EmbeddedNode.java>:
<https://builds.apache.org/job/karaf-decanter-master/org.apache.karaf.decanter$org.apache.karaf.decanter.elasticsearch-6.x/ws/src/main/java/org/apache/karaf/decanter/elasticsearch/EmbeddedNode.java>
uses unchecked or unsafe operations.
[INFO] <https://builds.apache.org/job/karaf-decanter-master/org.apache.karaf.decanter$org.apache.karaf.decanter.elasticsearch-6.x/ws/src/main/java/org/apache/karaf/decanter/elasticsearch/EmbeddedNode.java>:
Recompile with -Xlint:unchecked for details.
[INFO] 
[INFO] --- maven-resources-plugin:2.6:testResources (default-testResources) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory <https://builds.apache.org/job/karaf-decanter-master/org.apache.karaf.decanter$org.apache.karaf.decanter.elasticsearch-6.x/ws/src/test/resources>
[INFO] Copying 3 resources
[INFO] Copying 3 resources
[INFO] 
[INFO] --- maven-compiler-plugin:3.7.0:testCompile (default-testCompile) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 1 source file to <https://builds.apache.org/job/karaf-decanter-master/org.apache.karaf.decanter$org.apache.karaf.decanter.elasticsearch-6.x/ws/target/test-classes>
[INFO] 
[INFO] --- maven-surefire-plugin:2.17:test (default-test) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] Surefire report directory: <https://builds.apache.org/job/karaf-decanter-master/org.apache.karaf.decanter$org.apache.karaf.decanter.elasticsearch-6.x/ws/target/surefire-reports>

-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Running org.apache.karaf.decanter.elasticsearch.TestEmbeddedNode
[main] INFO org.apache.karaf.decanter.elasticsearch.EmbeddedNode - Starting Elasticsearch
node ...
ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging
only errors to the console. Set system property 'log4j2.debug' to show Log4j2 internal initialization
logging.
[main] INFO org.apache.karaf.decanter.elasticsearch.EmbeddedNode - Elasticsearch node created
Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 11.667 sec - in org.apache.karaf.decanter.elasticsearch.TestEmbeddedNode

Results :

Tests run: 1, Failures: 0, Errors: 0, Skipped: 0

[JENKINS] Recording test results
[INFO] 
[INFO] --- maven-bundle-plugin:4.2.0:bundle (default-bundle) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/elasticsearch/common/xcontent/support
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:elasticsearch-x-content]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/elasticsearch/cli
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:elasticsearch-cli]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/elasticsearch/transport
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:transport-netty4-client]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/elasticsearch/common/xcontent
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:elasticsearch-x-content]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/elasticsearch/common/logging
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:., Jar:elasticsearch]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/elasticsearch/common/unit
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:elasticsearch-core]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/elasticsearch/common/collect
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:elasticsearch-core]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/elasticsearch/bootstrap
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:elasticsearch-core]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/elasticsearch/common
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-x-content]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/elasticsearch/common/io
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:elasticsearch-core]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/codecs/lucene60
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:lucene-core, Jar:lucene-backward-codecs]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/util/fst
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:lucene-core, Jar:lucene-misc]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/codecs/lucene62
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:lucene-core, Jar:lucene-backward-codecs]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/analysis/miscellaneous
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:lucene-analyzers-common]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/document
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:lucene-core, Jar:lucene-misc, Jar:lucene-sandbox]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/queryparser/classic
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:lucene-queryparser]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/queries
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:lucene-queries]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/codecs
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:lucene-core, Jar:lucene-backward-codecs]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/codecs/lucene50
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:lucene-core, Jar:lucene-backward-codecs]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/index
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:lucene-core, Jar:lucene-misc, Jar:lucene-backward-codecs]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/spatial
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:lucene-spatial, Jar:lucene-spatial-extras]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/search/vectorhighlight
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:lucene-highlighter]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/spatial/util
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:lucene-spatial, Jar:lucene-spatial-extras]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/search/grouping
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:lucene-grouping]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/store
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:lucene-core, Jar:lucene-misc]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/geo
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:lucene-core, Jar:lucene-sandbox]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/search/uhighlight
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:lucene-highlighter]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/analysis/standard
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:lucene-core, Jar:lucene-analyzers-common]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/search
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:lucene-core, Jar:lucene-misc, Jar:lucene-sandbox]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/apache/lucene/search/suggest/analyzing
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:lucene-suggest]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:org/joda/time/format
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:elasticsearch, Jar:joda-time]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Split package, multiple jars provide the same package:META-INF/services
Use Import/Export Package directive -split-package:=(merge-first|merge-last|error|first) to
get rid of this warning
Package found in   [Jar:., Jar:elasticsearch, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-sandbox, Jar:lucene-suggest, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs]
Class path         [Jar:., Jar:elasticsearch, Jar:elasticsearch-core, Jar:elasticsearch-secure-sm,
Jar:elasticsearch-x-content, Jar:snakeyaml, Jar:jackson-core, Jar:jackson-dataformat-smile,
Jar:jackson-dataformat-yaml, Jar:jackson-dataformat-cbor, Jar:lucene-core, Jar:lucene-analyzers-common,
Jar:lucene-grouping, Jar:lucene-highlighter, Jar:lucene-join, Jar:lucene-memory, Jar:lucene-misc,
Jar:lucene-queries, Jar:lucene-queryparser, Jar:lucene-sandbox, Jar:lucene-spatial, Jar:lucene-spatial-extras,
Jar:lucene-spatial3d, Jar:lucene-suggest, Jar:elasticsearch-cli, Jar:jopt-simple, Jar:hppc,
Jar:joda-time, Jar:t-digest, Jar:HdrHistogram, Jar:log4j-api, Jar:log4j-core, Jar:lucene-backward-codecs,
Jar:transport-netty4-client, Jar:netty-buffer, Jar:netty-codec, Jar:netty-codec-http, Jar:netty-common,
Jar:netty-handler, Jar:netty-resolver, Jar:netty-transport, Jar:osgi.core, Jar:osgi.cmpn,
Jar:slf4j-api]
[WARNING] Bundle org.apache.karaf.decanter:org.apache.karaf.decanter.elasticsearch-6.x:bundle:2.3.0-SNAPSHOT
: Unused Private-Package instructions, no such package(s) on the class path: [com.carrotsearch.randomizedtesting,
com.vividsolutions.jts*, org.locationtech.spatial4j*, org.joda.convert*, org.noggit, !META-INF.services.org.apache.lucene.codecs.Codec]
[INFO] 
[INFO] --- build-helper-maven-plugin:1.10:attach-artifact (default) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] 
[INFO] --- maven-site-plugin:3.7.1:attach-descriptor (attach-descriptor) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] Skipping because packaging 'bundle' is not pom.
[INFO] 
[INFO] >>> maven-source-plugin:3.0.1:jar (attach-sources) > generate-sources @
org.apache.karaf.decanter.elasticsearch-6.x >>>
[INFO] 
[INFO] --- maven-enforcer-plugin:1.4.1:enforce (enforce-maven-version) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[WARNING] Failed to getClass for org.apache.maven.plugins.source.SourceJarMojo
[INFO] 
[INFO] <<< maven-source-plugin:3.0.1:jar (attach-sources) < generate-sources @
org.apache.karaf.decanter.elasticsearch-6.x <<<
[INFO] 
[INFO] 
[INFO] --- maven-source-plugin:3.0.1:jar (attach-sources) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] Building jar: <https://builds.apache.org/job/karaf-decanter-master/org.apache.karaf.decanter$org.apache.karaf.decanter.elasticsearch-6.x/ws/target/org.apache.karaf.decanter.elasticsearch-6.x-2.3.0-SNAPSHOT-sources.jar>
[INFO] 
[INFO] --- maven-javadoc-plugin:2.9:jar (attach-javadocs) @ org.apache.karaf.decanter.elasticsearch-6.x
---
[INFO] 
Loading source files for package org.apache.karaf.decanter.elasticsearch...
Loading source files for package org.elasticsearch.common.logging...
2 errors

Mime
View raw message