karaf-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gno...@apache.org
Subject [2/2] karaf git commit: Fix provisioning doc related to feature dependencies and ranges.
Date Tue, 06 Sep 2016 07:12:21 GMT
Fix provisioning doc related to feature dependencies and ranges.

Project: http://git-wip-us.apache.org/repos/asf/karaf/repo
Commit: http://git-wip-us.apache.org/repos/asf/karaf/commit/5742e9f1
Tree: http://git-wip-us.apache.org/repos/asf/karaf/tree/5742e9f1
Diff: http://git-wip-us.apache.org/repos/asf/karaf/diff/5742e9f1

Branch: refs/heads/master
Commit: 5742e9f13a9233081912b723ecbc7626b9b29080
Parents: 7fa2902
Author: Guillaume Nodet <gnodet@apache.org>
Authored: Fri Sep 2 08:21:44 2016 +0200
Committer: Guillaume Nodet <gnodet@apache.org>
Committed: Tue Sep 6 09:11:09 2016 +0200

----------------------------------------------------------------------
 manual/src/main/asciidoc/user-guide/provisioning.adoc | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/karaf/blob/5742e9f1/manual/src/main/asciidoc/user-guide/provisioning.adoc
----------------------------------------------------------------------
diff --git a/manual/src/main/asciidoc/user-guide/provisioning.adoc b/manual/src/main/asciidoc/user-guide/provisioning.adoc
index 789ac88..d4feca6 100644
--- a/manual/src/main/asciidoc/user-guide/provisioning.adoc
+++ b/manual/src/main/asciidoc/user-guide/provisioning.adoc
@@ -221,10 +221,12 @@ It's possible to define a version range for a dependent feature:
 
 The feature with the highest version available in the range will be installed.
 
-If a single version is specified, this version will be chosen.
+If a single version is specified, the range will be considered open-ended.
 
 If nothing is specified, the highest available will be installed.
 
+To specify an exact version, use a closed range such as `[3.1,3.1]`.
+
 ===== Feature prerequisites
 
 Prerequisite feature is special kind of dependency. If you will add `prerequisite` attribute
to dependant feature tag then it will force installation and also activation of bundles in
dependant feature before installation of actual feature. This may be handy in case if bundles
enlisted in given feature are not using pre installed URL such `wrap` or `war`.


Mime
View raw message