kafka-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Denny Lee <denny.g....@gmail.com>
Subject Re: Kafka 0.8 on Windows issues
Date Fri, 28 Jun 2013 19:50:54 GMT
Oh, I take it back - I forgot to clear out the ZK and kafkalogs folders.
 Once I did that and changed the log.dir=\\tmp\\kafka-logs then we're up
and running.  Thanks!


On Fri, Jun 28, 2013 at 7:53 AM, Jun Rao <junrao@gmail.com> wrote:

> Any error in state-change.log or controller.log?
>
> Thanks,
>
> Jun
>
>
> On Fri, Jun 28, 2013 at 12:09 AM, Denny Lee <denny.g.lee@gmail.com> wrote:
>
> > Quick follow up - I snagged the 0.8.0-beta1-candidate1 from github but
> I'm
> > still getting the leader error issue.  The good news is that it's not
> > pumping out a lot of warning messages.  Below is an excerpt of the
> > kafka-server-start.bat output - note that initially a successful leader
> > was elected but then we still get the ..failed due to Leader not location
> > for partition error.
> >
> >
> > [2013-06-27 23:52:27,938] INFO 0 successfully elected as leader
> > (kafka.server.ZookeeperLeaderElector)
> > ...
> > [2013-06-27 23:53:27,552] INFO [KafkaApi-0] Auto creation of topic foo
> > with 1 partitions and replication factor 1 is
> > successful!(kafka.server.KafkaApis)
> > ...
> > [2013-06-27 23:53:27,614] INFO Closing socket connection to /127.0.0.1.
> > (kafka.network.Processor)
> > ...
> > [2013-06-27 23:53:27,942] WARN [KafkaApi-0] Produce request with
> > correlation id 4 from client on partition [foo,0] failed due to Leader
> not
> > local for partition [foo,0] on broker 0 (kafka.server.KafkaApis)
> > ...
> >
> >
> >
> >
> >
> >
> >
> > On 6/27/13 11:14 PM, "Jun Rao" <junrao@gmail.com> wrote:
> >
> > >This issue was fixed in kafka-903. The fix is included in the
> 0.8.0-beta1
> > >release. Do you see the same issue in that version?
> > >
> > >Thanks,
> > >
> > >Jun
> > >
> > >
> > >On Thu, Jun 27, 2013 at 9:45 AM, Denny Lee <denny.g.lee@gmail.com>
> wrote:
> > >
> > >> Quick follow up ­ this looks a lot like KAFKA-876
> > >> <https://issues.apache.org/jira/browse/KAFKA-876>  so I'm trying
that
> > >>out
> > >> now.
> > >>
> > >> From:  Denny Lee <denny.g.lee@gmail.com>
> > >> Date:  Thursday, June 27, 2013 9:10 AM
> > >> To:  "users@kafka.apache.org" <users@kafka.apache.org>
> > >> Subject:  Kafka 0.8 on Windows issues
> > >>
> > >> While I was able to spin it up on OSX and Ubuntu without any issues,
> > >>when
> > >> running this on Windows, I get the following error message when I
> > >>execute
> > >> the consumer:
> > >> Š
> > >> WARN
> > >>
> > >>
> >
> >>[console-consumer-8585_tardis8-1372348635138-29591e5d-leader-finder-threa
> > >>d],
> > >> Failed to add fetcher for [test,0] to broker
> > >>id:0,host:10.0.1.10,port:9092
> > >> (kafka.consumer.ConsumerFetcherManager$$anon$1)
> > >> kafka.common.NotLeaderForPartitionException
> > >> Š
> > >>
> > >> The consumer console ends up pushing out a lot of messages to the
> > >>console
> > >> where there is successful connection, fetching of metadata, the above
> > >> warning, and then shutting down the thread and stopping.  Anyone else
> > >>run
> > >> into a similar problem and by any chance have a solution?
> > >>
> > >> The steps I had followed were:
> > >> - Grabbed the latest bits from github and ran sbt update, sbt package
> > >> - Updated the %\kafka\bin\windows batch files so that they were
> > >>pointing to
> > >> the windows folder
> > >> - Executed windows\zookeeper-server-start.bat from the %\kafka\bin
> > >>folder
> > >> - Executed windows\kafka-server-start.bat and
> > >> windows\kafka-console-producer.bat and they appear to look okay
> > >> - Then ran the windows\kafka-console-consumer.bat and it is apparent
> it
> > >>is
> > >> not connecting properly
> > >>
> > >> I've tried running this on Windows 8, Windows 2008 R2, and Windows
> 2012
> > >>as
> > >> well as tried using a standalone zookeeper 3.4.5 but with no luck.
> > >>
> > >> Any ideas?  Thanks in advance!
> > >>
> > >>
> > >>
> >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message