kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Yu (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (KAFKA-5946) Give connector method parameter better name
Date Mon, 19 Mar 2018 01:28:00 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-5946?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16392411#comment-16392411
] 

Ted Yu edited comment on KAFKA-5946 at 3/19/18 1:27 AM:
--------------------------------------------------------

Thanks for taking it .


was (Author: yuzhihong@gmail.com):
Thanks for taking it.

> Give connector method parameter better name
> -------------------------------------------
>
>                 Key: KAFKA-5946
>                 URL: https://issues.apache.org/jira/browse/KAFKA-5946
>             Project: Kafka
>          Issue Type: Improvement
>            Reporter: Ted Yu
>            Assignee: Tanvi Jaywant
>            Priority: Major
>              Labels: connector, newbie
>
> During the development of KAFKA-5657, there were several iterations where method call
didn't match what the connector parameter actually represents.
> [~ewencp] had used connType as equivalent to connClass because Type wasn't used to differentiate
source vs sink.
> [~ewencp] proposed the following:
> {code}
> It would help to convert all the uses of connType to connClass first, then standardize
on class == java class, type == source/sink, name == user-specified name.
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message