kafka-jira mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Yu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (KAFKA-5946) Give connector method parameter better name
Date Wed, 10 Jan 2018 11:38:00 GMT

     [ https://issues.apache.org/jira/browse/KAFKA-5946?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ted Yu updated KAFKA-5946:
--------------------------
    Labels: connector newbie usability  (was: connector usability)

> Give connector method parameter better name
> -------------------------------------------
>
>                 Key: KAFKA-5946
>                 URL: https://issues.apache.org/jira/browse/KAFKA-5946
>             Project: Kafka
>          Issue Type: Improvement
>            Reporter: Ted Yu
>              Labels: connector, newbie, usability
>
> During the development of KAFKA-5657, there were several iterations where method call
didn't match what the connector parameter actually represents.
> [~ewencp] had used connType as equivalent to connClass because Type wasn't used to differentiate
source vs sink.
> [~ewencp] proposed the following:
> {code}
> It would help to convert all the uses of connType to connClass first, then standardize
on class == java class, type == source/sink, name == user-specified name.
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message